summaryrefslogtreecommitdiff
path: root/sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild')
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild
index 94bbc2597dd0..8347767ca534 100644
--- a/sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.10-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit flag-o-matic systemd toolchain-funcs tmpfiles
+inherit flag-o-matic systemd toolchain-funcs tmpfiles readme.gentoo-r1
DESCRIPTION="Provides a caching directory on an already mounted filesystem"
HOMEPAGE="https://people.redhat.com/~dhowells/fscache/"
@@ -15,7 +15,6 @@ KEYWORDS="amd64 ~riscv x86"
IUSE="doc selinux"
RDEPEND="selinux? ( sec-policy/selinux-cachefilesd )"
-DEPEND=""
PATCHES=(
"${FILESDIR}"/${PN}-0.10.9-makefile.patch
@@ -34,6 +33,8 @@ src_prepare() {
src_install() {
default
+ readme.gentoo_create_doc
+
if use selinux; then
dodoc -r selinux
docompress -x /usr/share/doc/${PF}/selinux
@@ -52,12 +53,8 @@ src_install() {
pkg_postinst() {
tmpfiles_process ${PN}.conf
- [[ -d /var/cache/fscache ]] && return
- elog "Before CacheFiles can be used, a directory for local storage"
- elog "must be created. The default configuration of /etc/cachefilesd.conf"
- elog "uses /var/cache/fscache. The filesystem mounted there must support"
- elog "extended attributes (mount -o user_xattr)."
- echo ""
- elog "Once that is taken care of, start the daemon, add -o ...,fsc"
- elog "to the mount options of your network mounts, and let it fly!"
+ if [[ ! -d /var/cache/fscache ]]; then
+ FORCE_PRINT_ELOG=1
+ fi
+ readme.gentoo_print_elog
}