summaryrefslogtreecommitdiff
path: root/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild')
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild63
1 files changed, 19 insertions, 44 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
index 09617302a1b5..be2cd55914db 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
@@ -27,14 +27,16 @@ CRATES="
clap_derive@4.4.7
clap_lex@0.6.0
colorchoice@1.0.0
- colored@2.1.0
either@1.9.0
+ env_logger@0.10.2
errno-dragonfly@0.1.2
errno@0.2.8
errno@0.3.8
glob@0.3.1
heck@0.4.1
+ hermit-abi@0.3.9
home@0.5.9
+ is-terminal@0.4.12
itertools@0.12.1
lazy_static@1.4.0
lazycell@1.3.0
@@ -42,7 +44,7 @@ CRATES="
libloading@0.8.1
libudev-sys@0.1.4
linux-raw-sys@0.4.13
- log@0.4.20
+ log@0.4.22
memchr@2.7.1
memoffset@0.8.0
minimal-lexical@0.2.1
@@ -56,13 +58,15 @@ CRATES="
regex-automata@0.4.5
regex-syntax@0.8.2
regex@1.10.3
- rpassword@7.3.1
- rtoolbox@0.0.2
rustc-hash@1.1.0
- rustix@0.38.31
+ rustix@0.38.34
+ rustversion@1.0.17
shlex@1.3.0
strsim@0.10.0
+ strum@0.26.2
+ strum_macros@0.26.2
syn@2.0.48
+ termcolor@1.4.1
terminal_size@0.3.0
udev@0.7.0
unicode-ident@1.0.12
@@ -70,6 +74,7 @@ CRATES="
uuid@1.7.0
which@4.4.2
winapi-i686-pc-windows-gnu@0.4.0
+ winapi-util@0.1.8
winapi-x86_64-pc-windows-gnu@0.4.0
winapi@0.3.9
windows-sys@0.48.0
@@ -90,12 +95,14 @@ CRATES="
windows_x86_64_gnullvm@0.52.0
windows_x86_64_msvc@0.48.5
windows_x86_64_msvc@0.52.0
+ zeroize@1.8.1
+ zeroize_derive@1.4.2
"
-LLVM_COMPAT=( {16..17} )
-PYTHON_COMPAT=( python3_{10..12} )
+LLVM_COMPAT=( {16..18} )
+PYTHON_COMPAT=( python3_{10..13} )
-inherit cargo flag-o-matic llvm-r1 multiprocessing python-any-r1 shell-completion toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm-r1 python-any-r1 shell-completion toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
@@ -111,8 +118,8 @@ fi
LICENSE="Apache-2.0 BSD GPL-2 MIT"
SLOT="0"
-IUSE="fuse test"
-RESTRICT="!test? ( test )"
+IUSE="fuse"
+RESTRICT="test"
DEPEND="
app-arch/lz4:=
@@ -134,10 +141,6 @@ BDEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/docutils[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
')
$(unpacker_src_uri_depends)
$(llvm_gen_dep '
@@ -147,12 +150,9 @@ BDEPEND="
virtual/rust
"
+QA_FLAGS_IGNORED="/sbin/bcachefs"
+
python_check_deps() {
- if use test; then
- python_has_version \
- "dev-python/pytest[${PYTHON_USEDEP}]" \
- "dev-python/pytest-xdist[${PYTHON_USEDEP}]"
- fi
python_has_version "dev-python/docutils[${PYTHON_USEDEP}]"
}
@@ -166,7 +166,6 @@ src_unpack() {
git-r3_src_unpack
S="${S}/rust-src" cargo_live_src_unpack
else
- unpack ${P}.tar.gz
cargo_src_unpack
fi
}
@@ -191,36 +190,12 @@ src_compile() {
default
- use test && emake tests
-
local shell
for shell in bash fish zsh; do
./bcachefs completions ${shell} > ${shell}.completion || die
done
}
-src_test() {
- if ! use fuse; then
- EPYTEST_IGNORE=( tests/test_fuse.py )
- fi
- EPYTEST_DESELECT=(
- # Valgrind
- 'tests/test_fixture.py::test_read_after_free'
- 'tests/test_fixture.py::test_undefined'
- 'tests/test_fixture.py::test_write_after_free'
- 'tests/test_fixture.py::test_undefined_branch'
- 'tests/test_fixture.py::test_leak'
- 'tests/test_fixture.py::test_check'
- # Fails in portage because of usersandbox; ensure that these pass before bumping!
- 'tests/test_basic.py::test_format'
- 'tests/test_basic.py::test_fsck'
- 'tests/test_basic.py::test_list'
- 'tests/test_basic.py::test_list_inodes'
- 'tests/test_basic.py::test_list_dirent'
- )
- epytest -v -n "$(makeopts_jobs)"
-}
-
src_install() {
into /
dosbin bcachefs