summaryrefslogtreecommitdiff
path: root/sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild')
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild
index 35de8ac80ee3..5a6adc90c67f 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-1.2_p20230813.ebuild
@@ -117,9 +117,10 @@ declare -A GIT_CRATES=(
[bindgen]="https://gitlab.com/Matt.Jolly/rust-bindgen-bcachefs;f773267b090bf16b9e8375fcbdcd8ba5e88806a8;rust-bindgen-bcachefs-%commit%/bindgen"
)
+LLVM_MAX_SLOT=17
PYTHON_COMPAT=( python3_{10..12} )
-inherit cargo flag-o-matic multiprocessing python-any-r1 toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm multiprocessing python-any-r1 toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
@@ -153,6 +154,7 @@ DEPEND="
RDEPEND="${DEPEND}"
+# Clang is required for bindgen
BDEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
@@ -163,10 +165,15 @@ BDEPEND="
)
')
$(unpacker_src_uri_depends)
- sys-devel/clang
+ <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1))
+ virtual/pkgconfig
virtual/rust
"
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}"
+}
+
python_check_deps() {
if use test; then
python_has_version \
@@ -177,12 +184,17 @@ python_check_deps() {
}
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
src_unpack() {
if [[ ${PV} == "9999" ]]; then
git-r3_src_unpack
S="${S}/rust-src" cargo_live_src_unpack
else
- default
+ unpack ${P}.tar.gz
cargo_src_unpack
fi
}