summaryrefslogtreecommitdiff
path: root/sys-fs/bashmount/bashmount-4.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/bashmount/bashmount-4.3.2.ebuild')
-rw-r--r--sys-fs/bashmount/bashmount-4.3.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/bashmount/bashmount-4.3.2.ebuild b/sys-fs/bashmount/bashmount-4.3.2.ebuild
new file mode 100644
index 000000000000..71c5fb9802b5
--- /dev/null
+++ b/sys-fs/bashmount/bashmount-4.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bash script that uses udisks to mount removable devices without GUI"
+HOMEPAGE="https://github.com/jamielinux/bashmount"
+SRC_URI="https://github.com/jamielinux/bashmount/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# sys-apps/util-linux -> lsblk
+RDEPEND="
+ app-shells/bash:*
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-fs/udisks:2
+ virtual/eject"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+ doman ${PN}.1
+ dodoc NEWS
+}