summaryrefslogtreecommitdiff
path: root/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse/files/sparse-0.4.3-gentoo.patch')
-rw-r--r--sys-devel/sparse/files/sparse-0.4.3-gentoo.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch b/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
new file mode 100644
index 000000000000..6f46687d78b3
--- /dev/null
+++ b/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
@@ -0,0 +1,49 @@
+diff --git a/Makefile b/Makefile
+index 74905df..1f2b2b6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ OS = linux
+
+
+ CC = gcc
+-CFLAGS = -O2 -finline-functions -fno-strict-aliasing -g
++CFLAGS ?= -O2 -finline-functions -fno-strict-aliasing -g
+ CFLAGS += -Wall -Wwrite-strings
+ LDFLAGS += -g
+ AR = ar
+@@ -21,7 +21,8 @@ HAVE_GCC_DEP:=$(shell touch .gcc-test.c && \
+ echo 'yes'; rm -f .gcc-test.d .gcc-test.o .gcc-test.c)
+ HAVE_GTK2:=$(shell pkg-config --exists gtk+-2.0 2>/dev/null && echo 'yes')
+
+-CFLAGS += -DGCC_BASE=\"$(shell $(CC) --print-file-name=)\"
++GCC_BASE = $(shell $(CC) --print-file-name=)
++CFLAGS += -DGCC_BASE=\"$(GCC_BASE)\"
+
+ ifeq ($(HAVE_GCC_DEP),yes)
+ CFLAGS += -Wp,-MD,$(@D)/.$(@F).d
+@@ -113,7 +114,9 @@ SED_PC_CMD = 's|@version@|$(VERSION)|g; \
+
+ all: $(PROGRAMS) sparse.pc
+
+-install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
++all-installable: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
++
++install: all-installable
+ $(Q)install -d $(DESTDIR)$(BINDIR)
+ $(Q)install -d $(DESTDIR)$(LIBDIR)
+ $(Q)install -d $(DESTDIR)$(MAN1DIR)
+diff --git a/parse.h b/parse.h
+index 6b21e23..b26bd03 100644
+--- a/parse.h
++++ b/parse.h
+@@ -35,10 +35,6 @@ struct statement {
+ struct /* declaration */ {
+ struct symbol_list *declaration;
+ };
+- struct /* label_arg */ {
+- struct symbol *label;
+- struct statement *label_statement;
+- };
+ struct {
+ struct expression *expression;
+ struct expression *context;