summaryrefslogtreecommitdiff
path: root/sys-devel/remake
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/remake')
-rw-r--r--sys-devel/remake/Manifest3
-rw-r--r--sys-devel/remake/files/remake-4.2.1.1.4-fno-common.patch127
-rw-r--r--sys-devel/remake/remake-4.2.1.1.4-r1.ebuild3
3 files changed, 131 insertions, 2 deletions
diff --git a/sys-devel/remake/Manifest b/sys-devel/remake/Manifest
index 174af9cb0f30..e872845ddf17 100644
--- a/sys-devel/remake/Manifest
+++ b/sys-devel/remake/Manifest
@@ -1,4 +1,5 @@
AUX make-4.2.1-glob-v2.patch 1073 BLAKE2B bcced0694ed0206394d750452cec2c0ee8356fd8b779b9ee4d6fbf0d3dd736a0465b0f12a1629508669efb7c4ffe1d17f1aeb9b925d86e9e75a5b90119ddd5c9 SHA512 2f19578979cc5af622d6571e4d9c97e5567acd4036076e9c426a8d4505b6da191cf9b6edb1cecc0aff14efce52d3062c21d10a36d569743acdfc660007f928f4
+AUX remake-4.2.1.1.4-fno-common.patch 3096 BLAKE2B ca1fb0cd2382d1507239135f0aa2fe4c0d02414abd5c008a89ddae68d65589a8fc7244acfb7cf4881b3a44754208fbf05e54c8da2bc7317213b4bfa6ea4d4cfe SHA512 0d0751958e466bb2c40bff5b58d08a105e8b9c6884c02c05d93309f6014371f4ab0e2a3c38dd10cd73ecb3143076828d770031ea6c9aee63f945c15aa85774f3
DIST remake-4.2.1+dbg-1.4.tar.bz2 1508613 BLAKE2B f83bf8b1154d87d3c729b51797011511c6d9a249dffd212a551602a2af1c874d50d631d0f0e3f00d1b4484db758b7d167c416b0be185ad2a16897a077d04e9f4 SHA512 ffb7d641e0bc99794c17f634fe0aa5bf909c1e1c8eb14873dd27f2950d913db393c3532c34f417307eba351e8732c366131a23e661f5fec9529edc5d778da0d1
-EBUILD remake-4.2.1.1.4-r1.ebuild 922 BLAKE2B 8ab9739649111df005ed43060f46fc58788bb420861405f271cd9a81cd4c3508abb6175f314cbab9db184659f6499f1946915a5bdc27f4529dbf33cf64c2314f SHA512 fd5b4d212289a0dfff25967955a31e973fbf4cb013e8981da032c880ab3381b6770549540312feeaf4d10df4e621ca8a02d546f344a23de9d124fb2a0fc29508
+EBUILD remake-4.2.1.1.4-r1.ebuild 959 BLAKE2B 483247fef4339d53a5ef98d4d5529930204106bfd49ea2e293d31df4ad45ad21999d3b3ec05bddd8b02f438267c52bcf313e4fb11a6c72d0a4ffd646ab6bc792 SHA512 406017f4e2136046ffcea1b102652a28fb01bc895cdf749e19fea61d0d1b09824018bb10d8f050d9bd9cb8c09f4dd0e6a82cd5be60d520343cedaf7a84b7e21b
MISC metadata.xml 326 BLAKE2B 4ca7da15d02026b12d85b2329d0096bfc817d29b0618a97a61f54b9c6702b3cc89c4674510286c88b59eaa7142b98ff2fdada61ae5d56856b3e6a9e08116a954 SHA512 69c31da5d0fb8b94548ee398fc937405ae11224a415dc7ad6628c9b66362d43c4e3adcfba05016735298d31eba68faa19dab93f3d792629217660e51c382567c
diff --git a/sys-devel/remake/files/remake-4.2.1.1.4-fno-common.patch b/sys-devel/remake/files/remake-4.2.1.1.4-fno-common.patch
new file mode 100644
index 000000000000..4367bf9332b3
--- /dev/null
+++ b/sys-devel/remake/files/remake-4.2.1.1.4-fno-common.patch
@@ -0,0 +1,127 @@
+--- a/dep.h
++++ b/dep.h
+@@ -134,7 +134,7 @@
+ struct goaldep *read_all_makefiles (const char **makefiles);
+
+ /*! The chain of makefiles read by read_makefile. */
+-struct goaldep *read_makefiles;
++extern struct goaldep *read_makefiles;
+
+ void eval_buffer (char *buffer, const gmk_floc *floc);
+ enum update_status update_goal_chain (struct goaldep *goals);
+--- a/globals.c
++++ b/globals.c
+@@ -120,8 +120,6 @@
+ of each job stay together. */
+ int output_sync = OUTPUT_SYNC_NONE;
+
+-const char *default_shell;
+-
+ char *remote_description = 0;
+
+ /* Remember the original value of the SHELL variable, from the environment. */
+--- a/globals.h
++++ b/globals.h
+@@ -85,6 +85,12 @@
+ extern bool b_debugger_preread;
+
+ /* Remember the original value of the SHELL variable, from the environment. */
+-struct variable shell_var;
++extern struct variable shell_var;
++
++/**! The default value of SHELL and the shell that is used when issuing
++ commands on targets.
++*/
++extern const char *default_shell;
++
+
+ #endif /*GLOBALS_H*/
+--- a/main.c
++++ b/main.c
+@@ -40,6 +40,8 @@
+ # include <fcntl.h>
+ #endif
+
++struct goaldep *read_makefiles;
++
+ extern void initialize_stopchar_map ();
+
+ #if defined HAVE_WAITPID || defined HAVE_WAIT3
+--- a/main.h
++++ b/main.h
+@@ -35,10 +35,5 @@
+ /* is default_shell unixy? */
+ extern int unixy_shell;
+
+-/**! The default value of SHELL and the shell that is used when issuing
+- commands on targets.
+-*/
+-extern char *default_shell;
+-
+ /*! Print version information. */
+ extern void print_version (void);
+--- a/make.h
++++ b/make.h
+@@ -333,7 +333,7 @@
+ #endif
+ #ifdef SET_STACK_SIZE
+ # include <sys/resource.h>
+-struct rlimit stack_limit;
++extern struct rlimit stack_limit;
+ #endif
+
+ /* We have to have stdarg.h or varargs.h AND v*printf or doprnt to use
+--- a/print.h
++++ b/print.h
+@@ -39,7 +39,7 @@
+
+ /* Think of the below not as an enumeration but as #defines done in a
+ way that we'll be able to use the value in a gdb. */
+-enum debug_print_enums_e {
++extern enum debug_print_enums_e {
+ MAX_STACK_SHOW = 1000,
+ } debug_print_enums1;
+
+--- a/variable.c
++++ b/variable.c
+@@ -29,6 +29,7 @@
+ #endif
+ #include "hash.h"
+ #include "main.h"
++#include "globals.h"
+
+ /* Incremented every time we add or remove a global variable. */
+ static unsigned long variable_changenum;
+--- a/variable.h
++++ b/variable.h
+@@ -115,7 +115,6 @@
+ extern char *variable_buffer;
+ extern struct variable_set_list *current_variable_set_list;
+ extern struct variable *default_goal_var;
+-extern struct variable shell_var;
+
+ /* expand.c */
+ char *variable_buffer_output (char *ptr, const char *string, unsigned int length);
+--- a/debugger/file2line.h
++++ b/debugger/file2line.h
+@@ -19,7 +19,7 @@
+ Boston, MA 02111-1307, USA. */
+ #ifndef REMAKE_FILE2LINE
+ #define REMAKE_FILE2LINE
+-struct hash_table file2lines;
++extern struct hash_table file2lines;
+
+ typedef enum {
+ F2L_TARGET,
+--- a/debugger/file2line.c
++++ b/debugger/file2line.c
+@@ -26,6 +26,8 @@
+ #include "../rule.h"
+ #include "./file2line.h"
+
++struct hash_table file2lines;
++
+ unsigned long
+ file2lines_hash_1 (const void *key)
+ {
+
diff --git a/sys-devel/remake/remake-4.2.1.1.4-r1.ebuild b/sys-devel/remake/remake-4.2.1.1.4-r1.ebuild
index 16971ea81794..447b79c7375e 100644
--- a/sys-devel/remake/remake-4.2.1.1.4-r1.ebuild
+++ b/sys-devel/remake/remake-4.2.1.1.4-r1.ebuild
@@ -21,7 +21,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
PATCHES=(
- "${FILESDIR}/make-4.2.1-glob-v2.patch"
+ "${FILESDIR}"/make-4.2.1-glob-v2.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_configure() {