summaryrefslogtreecommitdiff
path: root/sys-devel/parity
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/parity')
-rw-r--r--sys-devel/parity/Manifest3
-rw-r--r--sys-devel/parity/metadata.xml20
-rw-r--r--sys-devel/parity/parity-2.0.1.ebuild77
3 files changed, 0 insertions, 100 deletions
diff --git a/sys-devel/parity/Manifest b/sys-devel/parity/Manifest
deleted file mode 100644
index 32051a7f705f..000000000000
--- a/sys-devel/parity/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST parity-2.0.1.tar.bz2 371662 BLAKE2B c0fca272665bbe346d5d5ca18e06c65209df61454310811b939239f8ba25ec7a08ad2f864fb43780329dc1f0120afdb6ea4ee2b4b42d2888860358aa1dc176f4 SHA512 3c96c87b87f40cb7affd6ee9a87c8e7cf628aedb44a2d3d89370a5b5e32a43cb15a897ae27425e9d6a00581ffd50a70c7a7481f1ca259eddd1e6f2310b554eb9
-EBUILD parity-2.0.1.ebuild 1827 BLAKE2B 6b86b3a7e188e205432c072da32a27981148429cee93b53b06cfc4dc76a5e2a686f5b5d6afe5433fb1e2044651946b5198b56536a3f0d8b5a3ce0774f755fa28 SHA512 a50791748cf102a47ecf33e1560e6d4db6f0f6e2a46aa6f6b3bbdb34adc398bd2c440e38cd3c545b6e67ca5a296ec9ed5faaca320635b9726445d8154d76962e
-MISC metadata.xml 951 BLAKE2B 220c8e7b21103b6a3ba4c044e3eb45b5f18d78aac6ed23d967c36c33383d1b927dde458cb02c211f276b8e154d17011a37cf8b696d7fd35ff50ade027373d2df SHA512 9d7262935aad1af1a099faf9d8ba1b40af956d2e090cb7668f2382afcc8d0fadb46ca7169cb0055ccb1fe8e73e36cec8fb2ada6125326b9092df3bb2b51b4065
diff --git a/sys-devel/parity/metadata.xml b/sys-devel/parity/metadata.xml
deleted file mode 100644
index 2dc9f71e7299..000000000000
--- a/sys-devel/parity/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">ssi-schaefer/parity</remote-id>
- </upstream>
- <use>
- <flag name="vc8_0">Enable support for Visual Studio 2005</flag>
- <flag name="vc9_0">Enable support for Visual Studio 2008</flag>
- <flag name="vc10_0">Enable support for Visual Studio 2010</flag>
- <flag name="vc11_0">Enable support for Visual Studio 2012</flag>
- <flag name="vc12_0">Enable support for Visual Studio 2013</flag>
- <flag name="vc14_0">Enable support for Visual Studio 2015</flag>
- <flag name="vc15">Enable support for Visual Studio 2017</flag>
- <flag name="vc16">Enable support for Visual Studio 2019</flag>
- <flag name="vcx64">Enable support for 64bit Visual Studio compilers</flag>
- <flag name="vcx86">Enable support for 32bit Visual Studio compilers</flag>
- </use>
-</pkgmetadata>
diff --git a/sys-devel/parity/parity-2.0.1.ebuild b/sys-devel/parity/parity-2.0.1.ebuild
deleted file mode 100644
index 6828908aeff8..000000000000
--- a/sys-devel/parity/parity-2.0.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == 9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="git@github.com:ssi-schaefer/parity.git https://github.com/ssi-schaefer/parity.git"
- BDEPEND="dev-util/confix"
-else
- SRC_URI="https://github.com/ssi-schaefer/${PN}/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS=""
-fi
-DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
-HOMEPAGE="https://github.com/ssi-schaefer/parity"
-
-parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
-parity-vcvers-legacy() { echo 8_0 9_0 ; }
-parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15 16 ; }
-parity-vcvers() {
- parity-vcvers-legacy
- parity-vcvers-current
-}
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="$(
- for a in $(parity-vcarchs); do echo "+vc${a%=*}"; done
- for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
- for v in $(parity-vcvers-current); do echo "+vc${v}"; done
-)"
-
-if [[ ${PV} == 9999 ]]; then
- src_prepare() {
- default
- confix --output || die
- eautoreconf
- }
-fi
-
-parity-enabled-vcarchs() {
- local enabled= a
- for a in $(parity-vcarchs) ; do
- if use vc${a%=*} ; then
- enabled+=",${a#*=}"
- fi
- done
- echo ${enabled#,}
-}
-
-parity-enabled-vcvers() {
- local enabled= v
- for v in $(parity-vcvers) ; do
- if use vc${v} ; then
- enabled+=",${v/_/.}"
- fi
- done
- echo ${enabled#,}
-}
-
-src_configure() {
- local myconf=(
- --enable-msvc-archs="$(parity-enabled-vcarchs)"
- --enable-msvc-versions="$(parity-enabled-vcvers)"
- --disable-default-msvc-version
- )
- econf "${myconf[@]}"
-}
-
-pkg_postinst() {
- if [[ -n ${ROOT} ]] ; then
- einfo "To enable all available MSVC versions, on the target machine please run:"
- einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
- else
- "${EPREFIX}"/usr/bin/parity-setup --enable-all
- fi
-}