summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-18.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-18.1.0.ebuild')
-rw-r--r--sys-devel/llvm/llvm-18.1.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-18.1.0.ebuild b/sys-devel/llvm/llvm-18.1.0.ebuild
index 4c955a46c3e0..af10d82f811a 100644
--- a/sys-devel/llvm/llvm-18.1.0.ebuild
+++ b/sys-devel/llvm/llvm-18.1.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm.org multilib-minimal pax-utils python-any-r1
+inherit cmake flag-o-matic llvm.org multilib-minimal pax-utils python-any-r1
inherit toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
@@ -346,6 +346,11 @@ get_distribution_components() {
}
multilib_src_configure() {
+ # ODR violations (bug #917536, bug #926529). Just do it for GCC for now
+ # to avoid people grumbling. GCC is, anecdotally, more likely to miscompile
+ # LLVM with LTO anyway (which is not necessarily its fault).
+ tc-is-gcc && filter-lto
+
local ffi_cflags ffi_ldflags
if use libffi; then
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)