summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-14.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-14.0.3.ebuild')
-rw-r--r--sys-devel/llvm/llvm-14.0.3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-14.0.3.ebuild b/sys-devel/llvm/llvm-14.0.3.ebuild
index 360436b21ec4..66789e47a596 100644
--- a/sys-devel/llvm/llvm-14.0.3.ebuild
+++ b/sys-devel/llvm/llvm-14.0.3.ebuild
@@ -51,6 +51,9 @@ BDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
') )
libffi? ( virtual/pkgconfig )
+ test? (
+ sys-apps/which
+ )
"
# There are no file collisions between these versions but having :0
# installed means llvm-config there will take precedence.
@@ -64,7 +67,7 @@ PDEPEND="
"
LLVM_COMPONENTS=( llvm cmake third-party )
-LLVM_MANPAGES=pregenerated
+LLVM_MANPAGES=1
LLVM_PATCHSET=${PV}
LLVM_USE_TARGETS=provide
llvm.org_set_globals
@@ -139,7 +142,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )