summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-14.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-14.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-14.0.0.9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-14.0.0.9999.ebuild b/sys-devel/llvm/llvm-14.0.0.9999.ebuild
index f89b54bbb6c4..71fdfeea8b60 100644
--- a/sys-devel/llvm/llvm-14.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-14.0.0.9999.ebuild
@@ -55,9 +55,9 @@ RDEPEND="${RDEPEND}
PDEPEND="sys-devel/llvm-common
binutils-plugin? ( >=sys-devel/llvmgold-${SLOT} )"
-LLVM_COMPONENTS=( llvm third-party )
+LLVM_COMPONENTS=( llvm cmake third-party )
LLVM_MANPAGES=build
-LLVM_PATCHSET=9999-1
+LLVM_PATCHSET=9999-r3
LLVM_USE_TARGETS=provide
llvm.org_set_globals
@@ -235,6 +235,7 @@ get_distribution_components() {
llvm-cxxdump
llvm-cxxfilt
llvm-cxxmap
+ llvm-debuginfod-find
llvm-diff
llvm-dis
llvm-dlltool
@@ -280,6 +281,7 @@ get_distribution_components() {
llvm-strip
llvm-symbolizer
llvm-tapi-diff
+ llvm-tli-checker
llvm-undname
llvm-windres
llvm-xray
@@ -437,6 +439,9 @@ multilib_src_configure() {
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure
+ grep -q -E "^CMAKE_PROJECT_VERSION_MAJOR(:.*)?=$(ver_cut 1)$" \
+ CMakeCache.txt ||
+ die "Incorrect version, did you update _LLVM_MASTER_MAJOR?"
multilib_is_native_abi && check_distribution_components
}