summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-15.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-15.0.7.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-15.0.7.ebuild36
1 files changed, 31 insertions, 5 deletions
diff --git a/sys-devel/llvm-common/llvm-common-15.0.7.ebuild b/sys-devel/llvm-common/llvm-common-15.0.7.ebuild
index 5c69c0a3337c..3419b7207944 100644
--- a/sys-devel/llvm-common/llvm-common-15.0.7.ebuild
+++ b/sys-devel/llvm-common/llvm-common-15.0.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit llvm.org
+inherit elisp-common llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
@@ -11,18 +11,44 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="emacs"
RDEPEND="
!sys-devel/llvm:0
"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
-LLVM_COMPONENTS=( llvm/utils/vim )
+LLVM_COMPONENTS=( llvm/utils )
llvm.org_set_globals
+SITEFILE="50llvm-gentoo.el"
+BYTECOMPFLAGS="-L emacs"
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile emacs/*.el
+}
+
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r */
+ doins -r vim/*/
# some users may find it useful
- newdoc README README.vim
- dodoc vimrc
+ newdoc vim/README README.vim
+ dodoc vim/vimrc
+
+ if use emacs ; then
+ elisp-install llvm emacs/*.{el,elc}
+ elisp-make-site-file "${SITEFILE}" llvm
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
}