summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 462b5c95a692..1725c16abdac 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -192,6 +192,9 @@ src_configure() {
# source-highlight is detected with pkg-config: bug #716558
export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+ # ensure proper compiler is detected for Clang builds: bug #831202
+ export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
+
econf "${myconf[@]}"
}