summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-9.1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-9.1.ebuild b/sys-devel/gdb/gdb-9.1.ebuild
index fa5deb598106..c27518d0c97d 100644
--- a/sys-devel/gdb/gdb-9.1.ebuild
+++ b/sys-devel/gdb/gdb-9.1.ebuild
@@ -46,7 +46,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml"
+IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -65,7 +65,7 @@ RDEPEND="
client? (
dev-libs/mpfr:0=
>=sys-libs/ncurses-5.2-r2:0=
- sys-libs/readline:0=
+ >=sys-libs/readline-7:0=
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
xml? ( dev-libs/expat )
@@ -74,6 +74,9 @@ RDEPEND="
source-highlight? (
dev-util/source-highlight
)
+ xxhash? (
+ dev-libs/xxhash
+ )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -171,6 +174,7 @@ src_configure() {
$(use_enable source-highlight)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
+ $(use_with xxhash)
)
fi
if use sparc-solaris || use x86-solaris ; then