summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-8.3.ebuild')
-rw-r--r--sys-devel/gdb/gdb-8.3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-devel/gdb/gdb-8.3.ebuild b/sys-devel/gdb/gdb-8.3.ebuild
index bbbb43834857..959d2b567d3e 100644
--- a/sys-devel/gdb/gdb-8.3.ebuild
+++ b/sys-devel/gdb/gdb-8.3.ebuild
@@ -60,7 +60,7 @@ SRC_URI="${SRC_URI}
LICENSE="GPL-2 LGPL-2"
SLOT="0"
if [[ ${PV} != 9999* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml"
REQUIRED_USE="
@@ -68,6 +68,13 @@ REQUIRED_USE="
|| ( client server )
"
+# ia64 kernel crashes when gdb testsuite is running
+# hppa kernel crashes when gdb testsuite is running
+RESTRICT="
+ hppa? ( test )
+ ia64? ( test )
+"
+
RDEPEND="
server? ( !dev-util/gdbserver )
client? (