summaryrefslogtreecommitdiff
path: root/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-768-r1.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-768-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
deleted file mode 100644
index e9f84fc168a6..000000000000
--- a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Apple branch of the GNU Debugger, 10.5"
-HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
-
-LICENSE="APSL-2 GPL-2"
-SLOT="0"
-
-KEYWORDS="~ppc-macos ~x86-macos"
-
-IUSE="nls"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- =dev-db/sqlite-3*"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/gdb-${PV}/src
-
-PATCHES=(
- "${FILESDIR}"/${P}-texinfo.patch
- "${FILESDIR}"/${P}-darwin-arch.patch
-)
-
-src_prepare() {
- default
- # for FSF gcc / gcc-apple:42
- sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
-}
-
-src_configure() {
- replace-flags -O? -O2
- econf \
- --disable-werror \
- $(use_enable nls) \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
- rm -r "${D}"/nukeme || die
- rm -Rf "${ED}"/usr/${CHOST} || die
- mv "${ED}"/usr/bin/gdb "${ED}"/
- rm -f "${ED}"/usr/bin/*
- mv "${ED}"/gdb "${ED}"/usr/bin/
-}