summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-9.2.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-9.2.0-r3.ebuild')
-rw-r--r--sys-devel/gcc/gcc-9.2.0-r3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-9.2.0-r3.ebuild b/sys-devel/gcc/gcc-9.2.0-r3.ebuild
index 107ecc45981b..398613c13bee 100644
--- a/sys-devel/gcc/gcc-9.2.0-r3.ebuild
+++ b/sys-devel/gcc/gcc-9.2.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -14,6 +14,13 @@ DEPEND="${RDEPEND}
elibc_glibc? ( >=sys-libs/glibc-2.13 )
>=${CATEGORY}/binutils-2.20"
+PATCHES=("${FILESDIR}"/${PN}-9.2.0-neg-insn-cost.patch)
+
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
fi
+
+src_prepare() {
+ toolchain_src_prepare
+ eapply "${FILESDIR}"/${PN}-9.2.0-neg-insn-cost.patch
+}