summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-4.9.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-4.9.4-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.9.4-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/gcc/gcc-4.9.4-r1.ebuild b/sys-devel/gcc/gcc-4.9.4-r1.ebuild
index 7580cc2b1b11..790cb126b299 100644
--- a/sys-devel/gcc/gcc-4.9.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.9.4-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
-PATCH_VER="2"
+PATCH_VER="3"
UCLIBC_VER="1.0"
# Hardened gcc 4 stuff
-PIE_VER="0.6.4"
+PIE_VER="2"
SPECS_VER="0.2.0"
SPECS_GCC_VER="4.4.3"
# arch/libc configurations known to be stable with {PIE,SSP}-by-default
@@ -40,11 +40,11 @@ src_prepare() {
fi
# Bug 638056
- epatch "${FILESDIR}/${P}-bootstrap.patch"
+ eapply "${FILESDIR}/${P}-bootstrap.patch"
toolchain_src_prepare
use vanilla && return 0
# Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+ [[ ${CHOST} == ${CTARGET} ]] && eapply "${FILESDIR}"/gcc-spec-env-r1.patch
}