summaryrefslogtreecommitdiff
path: root/sys-devel/gcc-config/gcc-config-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc-config/gcc-config-9999.ebuild')
-rw-r--r--sys-devel/gcc-config/gcc-config-9999.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/sys-devel/gcc-config/gcc-config-9999.ebuild b/sys-devel/gcc-config/gcc-config-9999.ebuild
index c27a2a1f2a82..e2c270403dd3 100644
--- a/sys-devel/gcc-config/gcc-config-9999.ebuild
+++ b/sys-devel/gcc-config/gcc-config-9999.ebuild
@@ -9,23 +9,23 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
inherit git-r3
else
- SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Utility to manage compilers"
HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+IUSE="+native-symlinks"
RDEPEND=">=sys-apps/gentoo-functions-0.10"
src_compile() {
emake CC="$(tc-getCC)" \
PV="${PV}" \
- SUBLIBDIR="$(get_libdir)"
+ SUBLIBDIR="$(get_libdir)" \
+ USE_NATIVE_LINKS="$(usex native-symlinks)"
}
src_install() {
@@ -37,12 +37,14 @@ src_install() {
}
pkg_postinst() {
- # Scrub eselect-compiler remains
- rm -f "${ROOT}"/etc/env.d/05compiler &
+ # Scrub eselect-compiler remains.
+ # To be removed in 2021.
+ rm -f "${ROOT}"/etc/env.d/05compiler
# We not longer use the /usr/include/g++-v3 hacks, as
# it is not needed ...
- rm -f "${ROOT}"/usr/include/g++{,-v3} &
+ # To be removed in 2021.
+ rm -f "${ROOT}"/usr/include/g++{,-v3}
# Do we have a valid multi ver setup ?
local x
@@ -50,5 +52,8 @@ pkg_postinst() {
gcc-config ${x}
done
- wait
+ # USE flag change can add or delete files in /usr/bin worth recaching
+ if [[ ! ${ROOT} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
+ eselect compiler-shadow update all
+ fi
}