summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-9999.ebuild')
-rw-r--r--sys-devel/clang/clang-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 10c2dbd94ce6..d769bda1d033 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -51,6 +51,7 @@ RDEPEND="${RDEPEND}
!<sys-devel/llvm-4.0.0_rc:0
!sys-devel/clang:0"
PDEPEND="
+ sys-devel/clang-common
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
default-libcxx? ( >=sys-libs/libcxx-${PV} )"
@@ -281,6 +282,13 @@ pkg_postinst() {
if [[ ${ROOT} == / && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
eselect compiler-shadow update all
fi
+
+ elog "You can find additional utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/clang"
+ elog "To use these scripts, you will need Python 2.7. Some of them are vim"
+ elog "integration scripts (with instructions inside). The run-clang-tidy.py"
+ elog "scripts requires the following additional package:"
+ elog " dev-python/pyyaml"
}
pkg_postrm() {