summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-5.0.1.ebuild')
-rw-r--r--sys-devel/clang/clang-5.0.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-devel/clang/clang-5.0.1.ebuild b/sys-devel/clang/clang-5.0.1.ebuild
index 9aeef0ecf6d4..d348af818eec 100644
--- a/sys-devel/clang/clang-5.0.1.ebuild
+++ b/sys-devel/clang/clang-5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils eapi7-ver flag-o-matic llvm \
- multilib-minimal pax-utils python-single-r1 toolchain-funcs
+ multilib-minimal pax-utils prefix python-single-r1 toolchain-funcs
MY_P=cfe-${PV/_/}.src
EXTRA_P=clang-tools-extra-${PV/_/}.src
@@ -30,7 +30,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="UoI-NCSA"
SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug default-compiler-rt default-libcxx doc +static-analyzer
test xml z3 kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
@@ -68,6 +68,8 @@ CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=(
# fix finding compiler-rt libs
"${FILESDIR}"/5.0.0/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+ # add Prefix include paths for Darwin
+ "${FILESDIR}"/5.0.0/darwin_prefix-include-paths.patch
)
# Multilib notes:
@@ -110,6 +112,11 @@ src_unpack() {
fi
}
+src_prepare() {
+ default
+ eprefixify lib/Frontend/InitHeaderSearch.cpp
+}
+
multilib_src_configure() {
local llvm_version=$(llvm-config --version) || die
local clang_version=$(ver_cut 1-3 "${llvm_version}")