summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-15.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-15.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang/clang-15.0.0.9999.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/sys-devel/clang/clang-15.0.0.9999.ebuild b/sys-devel/clang/clang-15.0.0.9999.ebuild
index 4cb70129b171..eed1670c87ea 100644
--- a/sys-devel/clang/clang-15.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake llvm llvm.org multilib multilib-minimal \
@@ -16,26 +16,32 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +pie +static-analyzer test xml"
+IUSE="
+ debug default-compiler-rt default-libcxx default-lld doc
+ llvm-libunwind +pie +static-analyzer test xml
+"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
-RDEPEND="
+DEPEND="
~sys-devel/llvm-${PV}:${SLOT}=[debug=,${MULTILIB_USEDEP}]
static-analyzer? ( dev-lang/perl:* )
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
- ${PYTHON_DEPS}"
+"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${DEPEND}
+"
BDEPEND="
+ ${PYTHON_DEPS}
>=dev-util/cmake-3.16
doc? ( $(python_gen_cond_dep '
dev-python/recommonmark[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
') )
xml? ( virtual/pkgconfig )
- ${PYTHON_DEPS}"
+"
PDEPEND="
sys-devel/clang-common
~sys-devel/clang-runtime-${PV}
@@ -45,7 +51,8 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind )
)
default-libcxx? ( >=sys-libs/libcxx-${PV} )
- default-lld? ( sys-devel/lld )"
+ default-lld? ( sys-devel/lld )
+"
LLVM_COMPONENTS=(
clang clang-tools-extra cmake