summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-13.0.1_rc1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-13.0.1_rc1.ebuild')
-rw-r--r--sys-devel/clang/clang-13.0.1_rc1.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/sys-devel/clang/clang-13.0.1_rc1.ebuild b/sys-devel/clang/clang-13.0.1_rc1.ebuild
index 6d0789546970..cf79f953833e 100644
--- a/sys-devel/clang/clang-13.0.1_rc1.ebuild
+++ b/sys-devel/clang/clang-13.0.1_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS=""
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +static-analyzer test xml kernel_FreeBSD"
+ doc llvm-libunwind +static-analyzer test xml"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -377,11 +377,6 @@ src_install() {
"/usr/lib/llvm/${SLOT}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {