summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-19.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0.9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
index 290d4ee063fe..4cc526c1c3d1 100644
--- a/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
@@ -168,15 +168,15 @@ src_install() {
newins - gentoo-hardened.cfg <<-EOF
# Some of these options are added unconditionally, regardless of
# USE=hardened, for parity with sys-devel/gcc.
- -fstack-clash-protection
- -fstack-protector-strong
+ -Xarch_host -fstack-clash-protection
+ -Xarch_host -fstack-protector-strong
-fPIE
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
if use amd64; then
cat >> "${ED}/etc/clang/gentoo-hardened.cfg" <<-EOF || die
- -fcf-protection=$(usex cet full none)
+ -Xarch_host -fcf-protection=$(usex cet full none)
EOF
fi