summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-19.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-19.0.0.9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
index 45196776694b..f260391ba4ab 100644
--- a/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-19.0.0.9999.ebuild
@@ -72,6 +72,11 @@ _doclang_cfg() {
@gentoo-common.cfg
@gentoo-common-ld.cfg
EOF
+ if [[ ${triple} == x86_64* ]]; then
+ cat >> "${ED}/etc/clang/${tool}.cfg" <<-EOF || die
+ @gentoo-cet.cfg
+ EOF
+ fi
done
if use kernel_Darwin; then
@@ -84,6 +89,11 @@ _doclang_cfg() {
# This configuration file is used by the ${triple}-clang-cpp driver.
@gentoo-common.cfg
EOF
+ if [[ ${triple} == x86_64* ]]; then
+ cat >> "${ED}/etc/clang/${triple}-clang-cpp.cfg" <<-EOF || die
+ @gentoo-cet.cfg
+ EOF
+ fi
# Install symlinks for triples with other vendor strings since some
# programs insist on mangling the triple.
@@ -174,11 +184,9 @@ src_install() {
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
EOF
- if use amd64; then
- cat >> "${ED}/etc/clang/gentoo-hardened.cfg" <<-EOF || die
- -Xarch_host -fcf-protection=$(usex cet full none)
- EOF
- fi
+ newins - gentoo-cet.cfg <<-EOF
+ -Xarch_host -fcf-protection=$(usex cet full none)
+ EOF
if use kernel_Darwin; then
newins - gentoo-hardened-ld.cfg <<-EOF