summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-16.0.6-r2.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r2.ebuild24
1 files changed, 1 insertions, 23 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
index bdbbd9cb2892..88fce05309fd 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="
default-compiler-rt default-libcxx default-lld llvm-libunwind
- hardened stricter
+ hardened
"
PDEPEND="
@@ -146,28 +146,6 @@ src_install() {
EOF
fi
- if use stricter; then
- newins - gentoo-stricter.cfg <<-EOF
- # This file increases the strictness of older clang versions
- # to match the newest upstream version.
-
- # clang-16 defaults
- -Werror=implicit-function-declaration
- -Werror=implicit-int
- -Werror=incompatible-function-pointer-types
-
- # constructs banned by C2x
- -Werror=deprecated-non-prototype
-
- # deprecated but large blast radius
- #-Werror=strict-prototypes
- EOF
-
- cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
- @gentoo-stricter.cfg
- EOF
- fi
-
local tool
for tool in clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF