summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-16.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
index 9d8ad198445d..841ceedb1077 100644
--- a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -29,6 +29,10 @@ PDEPEND="
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
"
+IDEPEND="
+ !default-compiler-rt? ( sys-devel/gcc-config )
+ !default-libcxx? ( sys-devel/gcc-config )
+"
LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
@@ -114,7 +118,8 @@ src_install() {
}
pkg_preinst() {
- if has_version sys-devel/gcc-config; then
+ if has_version -b sys-devel/gcc-config && has_version sys-devel/gcc
+ then
local gcc_path=$(gcc-config --get-lib-path 2>/dev/null)
if [[ -n ${gcc_path} ]]; then
cat >> "${ED}/etc/clang/gentoo-gcc-install.cfg" <<-EOF