summaryrefslogtreecommitdiff
path: root/sys-devel/automake/automake-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-9999.ebuild')
-rw-r--r--sys-devel/automake/automake-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
index 0fef18d0c6d4..0c72cfe6e473 100644
--- a/sys-devel/automake/automake-9999.ebuild
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -109,8 +109,13 @@ src_install() {
done
popd >/dev/null || die
- local major="$(ver_cut 1)"
- local minor="$(ver_cut 2)"
+ if [[ ${PV} == 9999 ]]; then
+ local major="89"
+ local minor="999"
+ else
+ local major="$(ver_cut 1)"
+ local minor="$(ver_cut 2)"
+ fi
local idx="$((99999-(major*1000+minor)))"
newenvd - "06automake${idx}" <<-EOF
INFOPATH="${infopath}"