summaryrefslogtreecommitdiff
path: root/sys-devel/automake-wrapper
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake-wrapper')
-rw-r--r--sys-devel/automake-wrapper/Manifest4
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-20221207.ebuild46
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-99999999.ebuild13
3 files changed, 58 insertions, 5 deletions
diff --git a/sys-devel/automake-wrapper/Manifest b/sys-devel/automake-wrapper/Manifest
index c04a5b1b928b..c8f7335f8434 100644
--- a/sys-devel/automake-wrapper/Manifest
+++ b/sys-devel/automake-wrapper/Manifest
@@ -1,4 +1,6 @@
AUX am-wrapper-11.sh 4626 BLAKE2B 2a96abc5b93db360a3ce074d84b21d7f875ff42d54f99030d8589b84efc94b411d8fb1a707716a060dc4a66c59f2a84d1e50a70f681faa62358fc7ae7a5a7d77 SHA512 452c0c52ef65b1ad5ad8d8f5c9c12cb9ff18eb03faaf7217c52a7dcf2a9832c7d4a59dbd8cc6325a0035a6650cc913f9b842615d053bd0f0c5c5177e660dbfca
+DIST autotools-wrappers-at-20221207.tar.gz 3646 BLAKE2B 82bec40e03ae5ec133252fd3c05c3fed537bb415e800918df9c9d783d48a9d76cbe60c53dd7daf6d94653d79fc52be8c089183dda996e8a72dd03ffa83098613 SHA512 12ea99721e6fc60a3ed7351d6c228aaf6e4eef0bd0444eda8cd742f74fa91150ef07bb52f6bcad4a350269e8032f5d4e204d2f2108b0d9c441ddd7f9755862b7
EBUILD automake-wrapper-11-r1.ebuild 879 BLAKE2B a26400af5a88b61752e86de8530adebe83b82233b82395412558172eaaef1304e8103f1aeeba65e73964a549a401cca15e56fad3ab0cea429fe05915c3a90fb8 SHA512 31f849c9a06e10adb2a8e9096d69abf5e70aef467ba5ff14ad86104363d4b9ad45ae2a8f9128f7777abf5134d8fb0c373f611fd98e36a69a01aaff35b0241b84
-EBUILD automake-wrapper-99999999.ebuild 1128 BLAKE2B adbcb1de2e8604db478f99f4b55d23833087c96ea44c575fe96581649deb871789c500d2a5aa81fa728736529733ec079dbdd3d499ba38a0fa1a464b0fbbdb28 SHA512 c19cea67a98aeff25aeaf982c17e38f7f4ab38851bdfe6b5d89cd927f49de0124cff3f95ffe18820bf24d3bc1ffe294aaa3eb835b4ab174769b1ebf07da24b3b
+EBUILD automake-wrapper-20221207.ebuild 1232 BLAKE2B 687c81360c28325284c8aea8c9b6c4c9763460625c2b8bfc24880c825421e051c133530eb3f03d132fb2162ead4769b500809bec15e80327ed3b1a6a34626e7b SHA512 8811454c9a8f76e6d13ff15c039ce3b00af914e6f48f4a36074d18c0cc0b43a1dd6fb4f21c25c45bffe866f946da6af0fc6f078c5718c264d1ba3d3fcb7c8c66
+EBUILD automake-wrapper-99999999.ebuild 1232 BLAKE2B 687c81360c28325284c8aea8c9b6c4c9763460625c2b8bfc24880c825421e051c133530eb3f03d132fb2162ead4769b500809bec15e80327ed3b1a6a34626e7b SHA512 8811454c9a8f76e6d13ff15c039ce3b00af914e6f48f4a36074d18c0cc0b43a1dd6fb4f21c25c45bffe866f946da6af0fc6f078c5718c264d1ba3d3fcb7c8c66
MISC metadata.xml 435 BLAKE2B 006f03645ce3cb9a4f7cad6411f3487500f58f351bbacfb6e1e3de494214fccb8b478a2cea35d289ee0a487fa7eaf31ca444cbf82d1d9eeee1822928e223009b SHA512 3b699336ca3dbf40bcfddb1db91f8d3803574c9c6765b477b93e50d756ac3c441e5bedfbbc71fcbea697a2f31b9a41fcbbb01a38d5acc8d29b48779a405f8f6c
diff --git a/sys-devel/automake-wrapper/automake-wrapper-20221207.ebuild b/sys-devel/automake-wrapper/automake-wrapper-20221207.ebuild
new file mode 100644
index 000000000000..2c7e8833a582
--- /dev/null
+++ b/sys-devel/automake-wrapper/automake-wrapper-20221207.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="autotools-wrappers-at-${PV}"
+
+DESCRIPTION="Wrapper for automake to manage multiple automake versions"
+HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/autotools-wrappers.git
+ https://github.com/gentoo/autotools-wrappers
+ "
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ # usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
+ if use prefix ; then
+ sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' am-wrapper-${PV}.sh || die
+ fi
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe am-wrapper.sh
+
+ local x=
+ for x in automake aclocal ; do
+ dosym -r /usr/$(get_libdir)/misc/am-wrapper.sh /usr/bin/${x}
+ done
+
+ keepdir /usr/share/aclocal
+}
diff --git a/sys-devel/automake-wrapper/automake-wrapper-99999999.ebuild b/sys-devel/automake-wrapper/automake-wrapper-99999999.ebuild
index ecb9a1b0530c..2c7e8833a582 100644
--- a/sys-devel/automake-wrapper/automake-wrapper-99999999.ebuild
+++ b/sys-devel/automake-wrapper/automake-wrapper-99999999.ebuild
@@ -1,19 +1,24 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+MY_P="autotools-wrappers-at-${PV}"
+
DESCRIPTION="Wrapper for automake to manage multiple automake versions"
HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/autotools-wrappers.git"
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/autotools-wrappers.git
+ https://github.com/gentoo/autotools-wrappers
+ "
inherit git-r3
else
SRC_URI="https://gitweb.gentoo.org/proj/autotools-wrappers.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- S="${WORKDIR}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"