summaryrefslogtreecommitdiff
path: root/sys-devel/autoconf/autoconf-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/autoconf/autoconf-9999.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-devel/autoconf/autoconf-9999.ebuild b/sys-devel/autoconf/autoconf-9999.ebuild
index b4a4e1ccac5a..2381a9c5fd5b 100644
--- a/sys-devel/autoconf/autoconf-9999.ebuild
+++ b/sys-devel/autoconf/autoconf-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/git/autoconf.git"
@@ -12,16 +12,22 @@ else
MY_P="${PN}-${MY_PV}"
#PATCH_TARBALL_NAME="${PN}-2.70-patches-01"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/zackweinberg.asc
+ inherit verify-sig
+
SRC_URI="
mirror://gnu/${PN}/${MY_P}.tar.xz
https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz
https://meyering.net/ac/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${MY_P}.tar.xz.sig )
"
- S="${WORKDIR}"/${MY_P}
+ S="${WORKDIR}"/${MY_P}
if [[ ${PV} != *_beta* ]] && ! [[ $(ver_cut 3) =~ [a-z] ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-zackweinberg )"
fi
inherit toolchain-autoconf
@@ -33,7 +39,7 @@ LICENSE="GPL-3+"
SLOT="$(ver_cut 1-2)"
IUSE="emacs"
-BDEPEND="
+BDEPEND+="
>=dev-lang/perl-5.10
>=sys-devel/m4-1.4.16
"