summaryrefslogtreecommitdiff
path: root/sys-devel/autoconf/autoconf-2.62-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.62-r1.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.62-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.62-r1.ebuild b/sys-devel/autoconf/autoconf-2.62-r1.ebuild
new file mode 100644
index 000000000000..574a0af6ce74
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.62-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-autoconf
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ !~sys-devel/${P}:2.5
+ >=sys-devel/autoconf-wrapper-13"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-revert-AC_C_BIGENDIAN.patch #228825
+ "${FILESDIR}"/${P}-at-keywords.patch
+ "${FILESDIR}"/${P}-fix-multiline-string.patch #217976
+)