summaryrefslogtreecommitdiff
path: root/sys-cluster/ucx/ucx-1.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ucx/ucx-1.5.2.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.5.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.5.2.ebuild b/sys-cluster/ucx/ucx-1.5.2.ebuild
new file mode 100644
index 000000000000..55ec075ba427
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}