summaryrefslogtreecommitdiff
path: root/sys-cluster/singularity
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest6
-rw-r--r--sys-cluster/singularity/singularity-3.7.1.ebuild73
-rw-r--r--sys-cluster/singularity/singularity-3.7.3.ebuild (renamed from sys-cluster/singularity/singularity-3.7.2.ebuild)0
3 files changed, 2 insertions, 77 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 58e14040c34e..81284aacf8ea 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,5 +1,3 @@
-DIST singularity-3.7.1.tar.gz 6121297 BLAKE2B 10399692559dbaf1a855229f4d3ff845af5b923d9a5b959638481ba58fd5bd04035fb751e5000aa44f816947d88ead85fbdceb8ad5cdb94aa54b0986cb922044 SHA512 ed87bd13bb4bbdcb49981cc02bf37e1db9a5d8fab3ef4314a15cfa391cb2210b55b2e54500fb03811eda8f31499ea7cead9a368a486da0cea0ac71037908c7cc
-DIST singularity-3.7.2.tar.gz 6268044 BLAKE2B d5a316046037dcb9c386f2d3b45204b77394cae273d0daa561282a354a463823c4be3c56e0935ff0a8dc9671cb841ad8cb75364b7652dce93ce099ede3e12ee3 SHA512 f31e383e645d394cc29e5b38da84ca805545e3226b069c696e667e7dde1569fa2373613f624c739482459a938e76e4e513062c19474685ccbfa5bd6162244466
-EBUILD singularity-3.7.1.ebuild 1921 BLAKE2B 46a2ccd1a3d721406e7d482c2941a650ec3c3e2159723fe17399f9e6b03b246314e3abcb4f9b4aee5180d710cdd86df6f6ff2683dc6f30f9227ab926e918c8f4 SHA512 7aa07a5cfa72bd5ab4623e334461749371c312156224c60d134b96827ec45a599a71f48221e8ff7f0baf7de09949d988073cbcd9d0fb9da870e6a405f963b7fa
-EBUILD singularity-3.7.2.ebuild 1922 BLAKE2B a3dc8db3e639bb4283e0bdc67ed5895615e2f46eabad0f7d0d0adf56036c4d5559e0fe3d984e3a6aeef048769b265c22dec4465078be44f333ad75044f77e468 SHA512 f7a2963da1560cfbc5a94f77a8c54b3417615ae45295aa20000ab53fa9c9538b1b759a9f60b9bb73a43f2133a7127f7d047f1318ba8f4407abc04988fc1e39c4
+DIST singularity-3.7.3.tar.gz 6444607 BLAKE2B eb37944f443e73ad258ba2b0f5e769c0e531fc9adc29ed1241940739b549b1bb409dfd8aff729229515c993ee2f842eb0ee00f0f52fec4d2e406f719c0f6e03c SHA512 56e797eb29a2fafaf6ccd730fb8cc9e35713020dacb4d19be02a7204272894360b0d254bd8066d9f14181b935f7179effbac2dfa776b2ff3e0e201388c372836
+EBUILD singularity-3.7.3.ebuild 1922 BLAKE2B a3dc8db3e639bb4283e0bdc67ed5895615e2f46eabad0f7d0d0adf56036c4d5559e0fe3d984e3a6aeef048769b265c22dec4465078be44f333ad75044f77e468 SHA512 f7a2963da1560cfbc5a94f77a8c54b3417615ae45295aa20000ab53fa9c9538b1b759a9f60b9bb73a43f2133a7127f7d047f1318ba8f4407abc04988fc1e39c4
MISC metadata.xml 451 BLAKE2B 0cca32721561e4100348cd884b88edad067a426736df27d4be6926525f9dd1315387dbefff84b983e69ab1972a44cd3a3a2c643bae676b413dab3482005d4ceb SHA512 da6f640f7df71bfe98fdabfe8ea69b1929b80b3c23d869dc496515a76d3f76c5d89d38843faf850184ddd7f624dd1e821dd50103f92e81aeb620a4bcd7151609
diff --git a/sys-cluster/singularity/singularity-3.7.1.ebuild b/sys-cluster/singularity/singularity-3.7.1.ebuild
deleted file mode 100644
index 437a7301250b..000000000000
--- a/sys-cluster/singularity/singularity-3.7.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-S=${WORKDIR}/${PN}
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}
diff --git a/sys-cluster/singularity/singularity-3.7.2.ebuild b/sys-cluster/singularity/singularity-3.7.3.ebuild
index 50873aff393c..50873aff393c 100644
--- a/sys-cluster/singularity/singularity-3.7.2.ebuild
+++ b/sys-cluster/singularity/singularity-3.7.3.ebuild