summaryrefslogtreecommitdiff
path: root/sys-cluster/sanlock
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/sanlock')
-rw-r--r--sys-cluster/sanlock/Manifest2
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.2.ebuild22
2 files changed, 17 insertions, 7 deletions
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index 67faed0969f1..d5da99ba867d 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -2,5 +2,5 @@ AUX sanlock-fence_sanlock-LDFLAGS.patch 504 BLAKE2B 11176057304ee5f841500921f1fa
AUX sanlock.initd 249 BLAKE2B 18bafba28ab4449c7f25ab2d14b4ac2d3cc89cf79bfb8f802fd180584becde8a5b9d919ac9ab887a4ebdfe8ea64e53f30b3785bc32875ccd2e25fa99a9278081 SHA512 5ed7b2d96cb875e2db0914ec7232fe8443c05de69e07d214ffc0adfafac5123694173373f831c5acf46d11aa4fca304b88e6e4c4ee2fbe5b033d173eea5aec36
AUX wdmd.initd 261 BLAKE2B 65b393f2f084896d3c17aa0345f9930badeec7a3ee4cc7e47bd0a35e47c18ea2bcf5afdc386c0da98988bc9fae479a68b504c244b55ab389ac7f5304c34282ae SHA512 9c7e980817c1c76868caff229b42a3d70e912abfd8c974bf5b856067bef79fbd3a5942b30bcb7d02869e2eba85e6f6ba3c861e9780046b01b25df1b39661b6c0
DIST sanlock-3.8.2.tar.gz 266780 BLAKE2B 5248d08225bcc2a19594a3dcd3872c8c69ca8b217d31f6263f2717e4594180d4ba4685c9679ce2f31b6a2dcb4fe9f3e6a5dd5ac3ed073aea02599e7bbc04390c SHA512 2fa92e16eee4d2f3dac452400522f7e90b93b71349d322564d5957e2d87fb4bd69f0b5617b05f4b296c272d6da9a404fccadbbfff106354a0e302c436593eaac
-EBUILD sanlock-3.8.2.ebuild 2080 BLAKE2B eb5ae95303db97b55dd80107936f776ec02856fa82514213c614b104cbf762cdedeb84f3fad3b7ee103b38f279a2c8a332003cb7034ebac2253b26380a0b128c SHA512 b200d000895c830b1f34e809b76910c96d2318b0dfb7b19bbffe5c4a947cb489886a5bfae147c26a072d8310e4d2003793b6310fa31bdb2c67ed843675815189
+EBUILD sanlock-3.8.2.ebuild 2162 BLAKE2B 49264c2dc1d0cba149548ca16435426e5dccf9b9966da8538dbb770cd15b1d93e69e0cc5806865a13f9a0595aca7206a28bdeb89f592c64ff05f626f9e031ec9 SHA512 3504d179f274a424e82daeea0c144eb5ed3d35fd4c68bce64512c7ad404adb0c29642bd1cc450ad2786c4e6a36ca4f2f79844faef7017616fe1af37b922fa313
MISC metadata.xml 368 BLAKE2B a15a411ea20eb7649f299e38704b394344194d7526f9bc92b27c0a26760d7dba05b1e5d483ff5f9ce73a6d1cd527a18ac905344a614c8dc31a0c1180b2be07e7 SHA512 2cc3ec3c99cfff2e0c576ab6c7b0a39460af875ba826ce0cf3c5a1a4f0f3def6170753c8d42af2fc7a139ad7f2135e309c3165bde83b4e7574292768c96e8086
diff --git a/sys-cluster/sanlock/sanlock-3.8.2.ebuild b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
index 8426d4f6d3ca..baada07ab2ae 100644
--- a/sys-cluster/sanlock/sanlock-3.8.2.ebuild
+++ b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
@@ -35,7 +35,7 @@ pkg_setup() {
if linux_config_exists; then
if ! linux_chkconfig_present SOFT_WATCHDOG; then
ewarn ""
- ewarn "$warning"
+ ewarn "${warning}"
ewarn ""
fi
else
@@ -47,19 +47,29 @@ pkg_setup() {
src_compile() {
for d in wdmd src fence_sanlock reset; do
- cd $d; emake; cd ..
+ cd ${d} || die
+ emake
+ cd .. || die
done
+
if use python; then
- cd python; python_foreach_impl emake; cd ..
+ cd python || die
+ python_foreach_impl emake
+ cd .. || die
fi
}
src_install() {
for d in wdmd src fence_sanlock reset; do
- cd $d; emake DESTDIR="${D}" LIBDIR="${EROOT}usr/$(get_libdir)" install; cd ..
+ cd ${d} || die
+ emake DESTDIR="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ cd .. || die
done
+
if use python; then
- cd python; python_foreach_impl emake DESTDIR="${D}" install; cd ..
+ cd python || die
+ python_foreach_impl emake DESTDIR="${D}" install
+ cd .. || die
fi
# config
@@ -78,7 +88,7 @@ src_install() {
# systemd
systemd_newunit init.d/sanlock.service.native sanlock.service
- sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native || die
systemd_newunit init.d/wdmd.service.native wdmd.service
systemd_dounit init.d/sanlk-resetd.service
#systemd_dounit ${FILESDIR}/fence_sanlockd.service