summaryrefslogtreecommitdiff
path: root/sys-cluster/prrte/prrte-3.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/prrte/prrte-3.0.6.ebuild')
-rw-r--r--sys-cluster/prrte/prrte-3.0.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/prrte/prrte-3.0.6.ebuild b/sys-cluster/prrte/prrte-3.0.6.ebuild
new file mode 100644
index 000000000000..6790ea5231fa
--- /dev/null
+++ b/sys-cluster/prrte/prrte-3.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="PMIx Reference RunTime Environment"
+HOMEPAGE="https://openpmix.github.io/"
+SRC_URI="https://github.com/openpmix/prrte/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+DEPEND="
+ dev-libs/libevent:=
+ sys-apps/hwloc:=
+ >=sys-cluster/pmix-4.2.4
+"
+RDEPEND="${DEPEND}"
+
+# There is no testsuite at least today.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ #
+ # Same issue as its companion project sys-cluster/pmix, and logically
+ # solvable in tandem (or never).
+ # https://github.com/openpmix/openpmix/issues/3350
+ filter-lto
+
+ econf
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}