summaryrefslogtreecommitdiff
path: root/sys-cluster/projections/projections-6.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/projections/projections-6.2.1.ebuild')
-rw-r--r--sys-cluster/projections/projections-6.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-cluster/projections/projections-6.2.1.ebuild b/sys-cluster/projections/projections-6.2.1.ebuild
new file mode 100644
index 000000000000..a3d6764d546a
--- /dev/null
+++ b/sys-cluster/projections/projections-6.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="Projections Performance Analysis Framework for Charm++ Applications"
+HOMEPAGE="http://charm.cs.uiuc.edu/"
+SRC_URI="http://charm.cs.illinois.edu/distrib/binaries/projections/projections_${PV}.tar.gz"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+LICENSE="charm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=virtual/jre-1.6
+ sys-cluster/charm[charmtracing]"
+
+src_install() {
+ java-pkg_newjar ${PN}.jar
+ java-pkg_dolauncher ${PN} \
+ --main projections.analysis.ProjMain \
+ --jar ${PN}.jar
+}