summaryrefslogtreecommitdiff
path: root/sys-cluster/osc-mpiexec
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/osc-mpiexec')
-rw-r--r--sys-cluster/osc-mpiexec/Manifest3
-rw-r--r--sys-cluster/osc-mpiexec/metadata.xml8
-rw-r--r--sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild65
3 files changed, 0 insertions, 76 deletions
diff --git a/sys-cluster/osc-mpiexec/Manifest b/sys-cluster/osc-mpiexec/Manifest
deleted file mode 100644
index 9f53a5df96a9..000000000000
--- a/sys-cluster/osc-mpiexec/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST mpiexec-0.83.tgz 207619 BLAKE2B c08799cbe30fd27a31344ea1472a22ccc4073b434d322acccc686c93d09824b4dce698d3dea7fb89367ec05c4ab90583e388501cf5c305b54eb5f321c970155b SHA512 e82828bad6d6f0cf8b2fa879d239460483af5164f696b26b21b138eeddf0d63a37748f8b540ceba6d328f90a64797a337934ba7152bdf2cbdde40be3f990a57d
-EBUILD osc-mpiexec-0.83.ebuild 1864 BLAKE2B fa92207ebed4e8e492c997fe6c5d96ba47e4c0e0fdda5de5b7cbca577bbfcd616feef5bf9e33d1a73fc586e2e54f73315d7086df6b93ebac641747645050875c SHA512 fbab616262dc3267f1594bc59ba065de5058ebcc07e2b7f88106ff98eabf0522a9e88e41743e68afdfba8035e3ea31cf6123ee2b619d8365a62b9fcb90c5bc6f
-MISC metadata.xml 253 BLAKE2B 2fbd23e1eeca2d6a1474e03aeaa1ad81f16f00141d906ca087f01b67a69e065cac2b3600c2da212ca9fdaf4765788a58ec12b6cd6a45323e5b524dbdb1ce0a77 SHA512 0894860713279dc39bbe7ce3491002710b62c4476198984a0deb6328cb0012c19d7a5546299960bbe600ee240e62a603dd4c4fa04325a753cc0b7c4044c30aba
diff --git a/sys-cluster/osc-mpiexec/metadata.xml b/sys-cluster/osc-mpiexec/metadata.xml
deleted file mode 100644
index 4a09d7ba8d61..000000000000
--- a/sys-cluster/osc-mpiexec/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>cluster@gentoo.org</email>
- <name>Gentoo Cluster Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild b/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild
deleted file mode 100644
index 22ec57399397..000000000000
--- a/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-MY_PN=${PN#osc-}
-DESCRIPTION="replacement for mpirun, integrates MPI with PBS"
-SRC_URI="http://www.osc.edu/~djohnson/mpiexec/${MY_PN}-${PV}.tgz"
-HOMEPAGE="http://www.osc.edu/~djohnson/mpiexec/index.php"
-
-DEPEND="sys-cluster/torque"
-RDEPEND="${DEPEND}
- net-misc/openssh"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-RESTRICT="test"
-# The test suite that is included with the source requires
-# the ability to qsub a number of jobs. Such behavior
-# obviously does not belong in the ebuild.
-
-src_compile() {
- local c="--with-default-comm=mpich-p4
- --with-pbs=/usr/
- --with-mpicc=/usr/bin/mpicc
- --with-mpif77=/usr/bin/mpif77"
-
- # The following at the recommendation of README, Cray specific.
- c="${c} --disable-mpich-rai"
-
- econf ${c} || die
- emake || die "compile failed"
-}
-
-src_install() {
- local f
- emake DESTDIR="${D}" install || die
-
- # And the following so that osc-mpiexec doesn't conflict with
- # the packaged mpiexec's that all the MPI-2 implementations have.
- for f in $(find "${D}" -name 'mpiexec*'); do
- mv ${f} $(dirname ${f})/osc-$(basename ${f}) \
- || die "Failed to prefix binary ${f} with osc-"
- done
-
- dodoc README README.lam ChangeLog
-}
-
-pkg_postinst() {
- elog "The OSC Mpiexec package typically installs it's binaries"
- elog "and manpages as 'mpiexec'. However, this ebuild renames"
- elog "those to be prefixed with 'osc-' in order to avoid blocking"
- elog "against the exact packages that osc-mpiexec is meant to"
- elog "work with."
- elog
- elog "The default communication device has been set to mpich-p4"
- elog "(ethernet). If you wish to use another communication"
- elog "device, either set MPIEXEC_COMM in your environment or use"
- elog "the --comm argument to mpiexec."
-}