summaryrefslogtreecommitdiff
path: root/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild')
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild b/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild
new file mode 100644
index 000000000000..d214cba5b919
--- /dev/null
+++ b/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+ keystone? ( ~sys-auth/keystone-${PV} )
+ swift? ( ~sys-cluster/swift-${PV} )
+ neutron? ( ~sys-cluster/neutron-${PV} )
+ glance? ( ~app-admin/glance-${PV} )
+ cinder? ( ~sys-cluster/cinder-${PV} )
+ nova? ( ~sys-cluster/nova-${PV} )
+ heat? ( ~sys-cluster/heat-${PV} )
+ placement? ( ~sys-cluster/placement-${PV} )
+"