summaryrefslogtreecommitdiff
path: root/sys-cluster/open-mx/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/open-mx/files')
-rw-r--r--sys-cluster/open-mx/files/omxoed.initd45
-rw-r--r--sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch14
2 files changed, 0 insertions, 59 deletions
diff --git a/sys-cluster/open-mx/files/omxoed.initd b/sys-cluster/open-mx/files/omxoed.initd
deleted file mode 100644
index 765842ed7f68..000000000000
--- a/sys-cluster/open-mx/files/omxoed.initd
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-checksystem() {
- if [ -c /dev/open-mx ]; then
- einfo "Open-MX module already loaded"
- return 0
- else
- einfo "Checking if Open-MX module present"
- if [ "x$(modprobe -l open-mx | grep open-mx)" == "x" ]; then
- eerror "open-mx not found!"
- return 1
- fi
- fi
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- checksystem || return 1
- if [ ! -c /dev/open-mx ]; then
- ebegin "Loading open-mx module"
- modprobe -q open-mx
- fi
- start-stop-daemon --start --exec /usr/bin/omxoed \
- --background --make-pidfile \
- --pidfile /var/run/omeoed.pid
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --exec /usr/bin/omxoed \
- --pidfile /var/run/omeoed.pid
- eend $?
-}
-
-status() {
- ebegin "Showing current active Open-MX peers"
- omx_info -q
-}
diff --git a/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch b/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch
deleted file mode 100644
index e082865c235a..000000000000
--- a/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.am 2011-07-15 02:42:53.000000000 +0400
-+++ Makefile.am 2011-07-15 02:43:02.000000000 +0400
-@@ -20,11 +20,6 @@
-
- SUBDIRS =
-
--# Driver
--if OMX_BUILD_DRIVER
-- SUBDIRS += driver/linux
--endif
--
- # Library
- if OMX_BUILD_LIBRARY
- SUBDIRS += libopen-mx tools tests tests/mx