summaryrefslogtreecommitdiff
path: root/sys-cluster/legion/legion-17.02.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/legion/legion-17.02.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-17.02.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sys-cluster/legion/legion-17.02.0.ebuild b/sys-cluster/legion/legion-17.02.0.ebuild
deleted file mode 100644
index 415747a8aa60..000000000000
--- a/sys-cluster/legion/legion-17.02.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A data-centric parallel programming system"
-HOMEPAGE="https://legion.stanford.edu/"
-SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="gasnet +hwloc"
-
-DEPEND="
- gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
- "
-
-S="${WORKDIR}/${PN}-${P}"
-
-src_configure() {
- mycmakeargs=(
- -DLegion_USE_HWLOC=$(usex hwloc)
- -DLegion_USE_GASNet=$(usex gasnet)
- -DBUILD_SHARED_LIBS=ON
- -DLegion_BUILD_EXAMPLES=ON
- -DLegion_BUILD_TESTS=ON
- -DLegion_BUILD_TUTORIAL=ON
- )
- cmake-utils_src_configure
-}