summaryrefslogtreecommitdiff
path: root/sys-cluster/hubble/hubble-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hubble/hubble-0.10.0.ebuild')
-rw-r--r--sys-cluster/hubble/hubble-0.10.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-cluster/hubble/hubble-0.10.0.ebuild b/sys-cluster/hubble/hubble-0.10.0.ebuild
new file mode 100644
index 000000000000..c9c9ba326b12
--- /dev/null
+++ b/sys-cluster/hubble/hubble-0.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# make sure this gets updated on every bump
+GIT_HASH=daec1c89
+
+DESCRIPTION="Network, Service & Security Observability for Kubernetes using eBPF"
+HOMEPAGE="https://cilium.io"
+SRC_URI="https://github.com/cilium/hubble/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake GIT_HASH=${GIT_HASH}
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin hubble
+}