summaryrefslogtreecommitdiff
path: root/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild')
-rw-r--r--sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild b/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild
new file mode 100644
index 000000000000..d5947540f5bd
--- /dev/null
+++ b/sys-cluster/feedbackd-agent/feedbackd-agent-0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="system for dynamic feedback of server loads in a Linux Virtual Server (LVS)-based cluster"
+HOMEPAGE="http://ozlabs.org/~jk/projects/feedbackd/"
+SRC_URI="mirror://sourceforge/feedbackd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xml-config=/usr/bin/xml2-config \
+ --with-perl=/usr/bin/perl \
+ || die "bad ./configure"
+
+ emake || die
+}
+
+src_install() {
+ #make DESTDIR=${D} install || die
+ einstall || die
+ dodoc ChangeLog NEWS README
+}