summaryrefslogtreecommitdiff
path: root/sys-cluster/charliecloud/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/charliecloud/files')
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.30-dash.patch48
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.31-realpath_return.patch32
2 files changed, 0 insertions, 80 deletions
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.30-dash.patch b/sys-cluster/charliecloud/files/charliecloud-0.30-dash.patch
deleted file mode 100644
index ba76e3fee59f..000000000000
--- a/sys-cluster/charliecloud/files/charliecloud-0.30-dash.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 1fb019b26d54f777ea7a2781f96adec369a25cbc Mon Sep 17 00:00:00 2001
-From: Oliver Freyermuth <o.freyermuth@googlemail.com>
-Date: Tue, 17 Jan 2023 19:00:11 +0100
-Subject: [PATCH] PR #1538: configure: Remove bashisms, fix dash compatibility
-Bug: https://bugs.gentoo.org/890873
-Bug: https://github.com/hpc/charliecloud/pull/1538
-
-+= and |& are not supported by systems using dash as shell.
----
- configure.ac | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 683a532..1c878d7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -216,15 +216,15 @@ AC_PROG_CC
- # Set up CFLAGS.
- ch_cflags='-std=c99 -Wall'
- AS_IF([test -n "$lib_libsquashfuse"],
-- [ch_cflags+=" -I$inc_libsquashfuse -L$lib_libsquashfuse"
-+ [ch_cflags="$ch_cflags -I$inc_libsquashfuse -L$lib_libsquashfuse"
- # Without this, clang fails with "error: argument unused during
- # compilation" on the -L. GCC ignores it.
-- ch_cflags+=' -Wno-unused-command-line-argument'])
-+ ch_cflags="$ch_cflags -Wno-unused-command-line-argument"])
- AS_IF([test $use_werror = yes],
-- [ch_cflags+=' -Werror'])
-+ [ch_cflags="$ch_cflags -Werror"])
-
- AX_CHECK_COMPILE_FLAG([$ch_cflags], [
-- CFLAGS+=" $ch_cflags"
-+ CFLAGS="$CFLAGS $ch_cflags"
- ], [
- AC_MSG_ERROR([no suitable C99 compiler found])
- ])
-@@ -434,7 +434,7 @@ CH_CHECK_VERSION([GIT], [$vmin_git], [--version | cut -d' ' -f3])
- # DOT
- vmin_dot=2.30.1
- AC_CHECK_PROG([DOT], [dot], [dot])
--CH_CHECK_VERSION([DOT], [$vmin_dot], [dot -V |& cut -d' ' -f5])
-+CH_CHECK_VERSION([DOT], [$vmin_dot], [dot -V 2>&1 | cut -d' ' -f5])
-
- # git2dot
- vmin_git2dot=0.8.3
---
-2.38.2
-
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.31-realpath_return.patch b/sys-cluster/charliecloud/files/charliecloud-0.31-realpath_return.patch
deleted file mode 100644
index 7b320fa9dbab..000000000000
--- a/sys-cluster/charliecloud/files/charliecloud-0.31-realpath_return.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From e6d25474fcd326ae657c08d7b49606aeabc98b51 Mon Sep 17 00:00:00 2001
-From: Oliver Freyermuth <o.freyermuth@googlemail.com>
-Date: Sat, 28 Jan 2023 21:25:09 +0100
-Subject: [PATCH] ch-misc: Do not check errno in realpath_ unless realpath
- returns NULL
-Bug: https://github.com/hpc/charliecloud/pull/1550
-
-glibc's realpath may set errno also on success, as POSIX specifies
-errno should only be checked after realpath if the return value is not NULL.
-
-See for example:
- https://bugzilla.redhat.com/show_bug.cgi?id=1916968
----
- bin/ch_misc.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/bin/ch_misc.c b/bin/ch_misc.c
-index 04ac52a..93a3339 100644
---- a/bin/ch_misc.c
-+++ b/bin/ch_misc.c
-@@ -589,7 +589,7 @@ char *realpath_(const char *path, bool fail_ok)
- errno = 0;
- pathc = realpath(path, NULL);
-
-- if (errno != 0) {
-+ if (pathc == NULL && errno != 0) {
- if (fail_ok) {
- T_ (pathc = strdup(path));
- } else {
---
-2.39.1
-