summaryrefslogtreecommitdiff
path: root/sys-cluster/charliecloud/charliecloud-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/charliecloud/charliecloud-9999.ebuild')
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild49
1 files changed, 34 insertions, 15 deletions
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index c838d73e90e9..54113d039cd4 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit python-single-r1
+inherit autotools eutils python-single-r1
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]] ; then
S="${WORKDIR}/${P}"
else
SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~x86 ~x86-linux"
fi
DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
@@ -21,7 +21,7 @@ HOMEPAGE="https://hpc.github.io/charliecloud/"
SLOT="0"
LICENSE="Apache-2.0"
-IUSE="doc examples +pv squashfuse"
+IUSE="ch-grow doc examples +pv +squashfs squashfuse"
# Extensive test suite exists, but downloads container images
# directly and via Docker and installs packages inside using apt/yum.
@@ -32,9 +32,15 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
pv? ( sys-apps/pv )
- squashfuse? ( sys-fs/squashfuse )
-"
+ squashfs? ( sys-fs/squashfs-tools )
+ squashfuse? ( sys-fs/squashfuse )"
DEPEND="
+ ch-grow? (
+ $(python_gen_cond_dep '
+ dev-python/lark-parser[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
doc? (
$(python_gen_cond_dep '
dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
@@ -43,16 +49,29 @@ DEPEND="
net-misc/rsync
)"
-src_compile() {
- emake
- use doc && emake -C doc-src
+src_prepare() {
+ default
+ eautoreconf
}
-src_install() {
- emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" LIBEXEC_DIR="libexec/${PF}"
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- einstalldocs
+src_configure() {
+ local econf_args=()
+ econf_args+=(
+ $(use_enable doc html)
+ $(use_enable ch-grow)
+ # Libdir is used as a libexec-style destination.
+ --libdir="${EPREFIX}"/usr/lib
+ # Attempts to call python-exec directly otherwise.
+ --with-sphinx-python=${PYTHON}
+ )
+ econf "${econf_args[@]}"
+}
+
+pkg_postinst() {
+ elog "Various builders are supported, as alternative "
+ elog "to the internal ch-grow. The following packages "
+ elog "can be installed to get the corresponding support."
+
+ optfeature "Building with Buildah" app-emulation/buildah
+ optfeature "Building with Docker" app-emulation/docker
}