summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.15-no-virtualenvs.patch (renamed from sys-cluster/ceph/files/ceph-15.2.13-no-virtualenvs.patch)8
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch36
2 files changed, 40 insertions, 4 deletions
diff --git a/sys-cluster/ceph/files/ceph-15.2.13-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-15.2.15-no-virtualenvs.patch
index 665bb8914264..5ef7fb3a73e1 100644
--- a/sys-cluster/ceph/files/ceph-15.2.13-no-virtualenvs.patch
+++ b/sys-cluster/ceph/files/ceph-15.2.15-no-virtualenvs.patch
@@ -1,5 +1,5 @@
diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
-index c9ee8c1b8f..09f75543da 100644
+index c9ee8c1b8f6..09f75543da2 100644
--- a/cmake/modules/AddCephTest.cmake
+++ b/cmake/modules/AddCephTest.cmake
@@ -68,14 +68,6 @@ function(add_tox_test name)
@@ -18,7 +18,7 @@ index c9ee8c1b8f..09f75543da 100644
NAME ${test_name}
COMMAND ${CMAKE_SOURCE_DIR}/src/script/run_tox.sh
diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
-index 4224499c47..9a6c87595b 100644
+index 9166553dc73..9a6c87595b9 100644
--- a/src/ceph-volume/CMakeLists.txt
+++ b/src/ceph-volume/CMakeLists.txt
@@ -8,22 +8,6 @@ if(FREEBSD)
@@ -30,7 +30,7 @@ index 4224499c47..9a6c87595b 100644
-
-add_custom_command(
- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
+- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
- COMMENT "ceph-volume venv is being created")
-
@@ -45,7 +45,7 @@ index 4224499c47..9a6c87595b 100644
DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
-index 92e4cdc538..3153c93c45 100644
+index 92e4cdc538b..3153c93c459 100644
--- a/src/pybind/mgr/dashboard/CMakeLists.txt
+++ b/src/pybind/mgr/dashboard/CMakeLists.txt
@@ -5,9 +5,6 @@ function(add_npm_command)
diff --git a/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch b/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
new file mode 100644
index 000000000000..3b38c1708733
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
@@ -0,0 +1,36 @@
+From 4c13a798dcf2e783afd7558bf3541dc025de854a Mon Sep 17 00:00:00 2001
+From: Nathan Cutler <ncutler@suse.com>
+Date: Tue, 27 Jul 2021 15:27:58 +0200
+Subject: [PATCH] compression/snappy: use uint32_t to be compatible with 1.1.9
+
+The snappy project made the following change in snappy.h between version 1.1.8
+and 1.1.9:
+
+< bool GetUncompressedLength(Source* source, uint32_t* result);
+---
+> bool GetUncompressedLength(Source* source, uint32* result);
+
+This causes Ceph to FTBFS with snappy 1.1.9.
+
+Thanks to Chris Denice for bringing this to our attention via Redmine.
+
+Fixes: https://tracker.ceph.com/issues/50934
+Signed-off-by: Nathan Cutler <ncutler@suse.com>
+---
+ src/compressor/snappy/SnappyCompressor.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/compressor/snappy/SnappyCompressor.h b/src/compressor/snappy/SnappyCompressor.h
+index 25393f8dc1ff4..93206c4007bed 100644
+--- a/src/compressor/snappy/SnappyCompressor.h
++++ b/src/compressor/snappy/SnappyCompressor.h
+@@ -97,8 +97,8 @@ class SnappyCompressor : public Compressor {
+ if (qat_enabled)
+ return qat_accel.decompress(p, compressed_len, dst, compressor_message);
+ #endif
+- snappy::uint32 res_len = 0;
+ BufferlistSource source_1(p, compressed_len);
++ uint32_t res_len = 0;
+ if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
+ return -1;
+ }