summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch37
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-boost-sonames.patch334
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-cflags.patch13
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-dpdk-cflags.patch30
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch11
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-mgr-python-version.patch17
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-no-virtualenvs.patch54
7 files changed, 0 insertions, 496 deletions
diff --git a/sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch b/sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch
deleted file mode 100644
index 1eb42b3e5ad6..000000000000
--- a/sys-cluster/ceph/files/ceph-13.2.5-no-automagic-deps.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- ceph-13.2.5.orig/src/rocksdb/CMakeLists.txt 2019-03-20 11:39:25.065954652 -0700
-+++ ceph-13.2.5/src/rocksdb/CMakeLists.txt 2019-03-20 13:18:01.548085828 -0700
-@@ -286,18 +286,24 @@
- endif()
- endif()
-
--find_package(NUMA)
--if(NUMA_FOUND)
-- add_definitions(-DNUMA)
-- include_directories(${NUMA_INCLUDE_DIR})
-- list(APPEND THIRDPARTY_LIBS ${NUMA_LIBRARIES})
-+option(WITH_NUMA "build with UBSAN" OFF)
-+if(WITH_NUMA)
-+ find_package(NUMA)
-+ if(NUMA_FOUND)
-+ add_definitions(-DNUMA)
-+ include_directories(${NUMA_INCLUDE_DIR})
-+ list(APPEND THIRDPARTY_LIBS ${NUMA_LIBRARIES})
-+ endif()
- endif()
-
--find_package(TBB)
--if(TBB_FOUND)
-- add_definitions(-DTBB)
-- include_directories(${TBB_INCLUDE_DIR})
-- list(APPEND THIRDPARTY_LIBS ${TBB_LIBRARIES})
-+option(WITH_TBB "build with UBSAN" OFF)
-+if(WITH_TBB)
-+ find_package(TBB)
-+ if(TBB_FOUND)
-+ add_definitions(-DTBB)
-+ include_directories(${TBB_INCLUDE_DIR})
-+ list(APPEND THIRDPARTY_LIBS ${TBB_LIBRARIES})
-+ endif()
- endif()
-
- # Used to run CI build and tests so we can run faster
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-boost-sonames.patch b/sys-cluster/ceph/files/ceph-14.2.0-boost-sonames.patch
deleted file mode 100644
index 497d59530511..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-boost-sonames.patch
+++ /dev/null
@@ -1,334 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dbabecbe97..d12b696bb5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -640,7 +640,7 @@ set(BOOST_HEADER_COMPONENTS container)
-
- if(WITH_MGR)
- list(APPEND BOOST_COMPONENTS
-- python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR})
-+ python-${MGR_PYTHON_VERSION_MAJOR}.${MGR_PYTHON_VERSION_MINOR})
- endif()
- if(WITH_BOOST_CONTEXT)
- list(APPEND BOOST_COMPONENTS context coroutine)
-diff --git a/cmake/modules/FindBoost.cmake b/cmake/modules/FindBoost.cmake
-index bfab4ca436..90ed0cbb17 100644
---- a/cmake/modules/FindBoost.cmake
-+++ b/cmake/modules/FindBoost.cmake
-@@ -1181,10 +1181,10 @@ endif()
- # on all platforms to keep end user code free from platform dependent
- # code. Also provide convenience targets to disable autolinking and
- # enable dynamic linking.
--if(NOT TARGET Boost::diagnostic_definitions)
-- add_library(Boost::diagnostic_definitions INTERFACE IMPORTED)
-- add_library(Boost::disable_autolinking INTERFACE IMPORTED)
-- add_library(Boost::dynamic_linking INTERFACE IMPORTED)
-+if(NOT TARGET boost_diagnostic_definitions)
-+ add_library(boost_diagnostic_definitions INTERFACE IMPORTED)
-+ add_library(boost_disable_autolinking INTERFACE IMPORTED)
-+ add_library(boost_dynamic_linking INTERFACE IMPORTED)
- endif()
- if(WIN32)
- # In windows, automatic linking is performed, so you do not have
-@@ -1205,11 +1205,11 @@ if(WIN32)
- # code to emit a #pragma message each time a library is selected
- # for linking.
- set(Boost_LIB_DIAGNOSTIC_DEFINITIONS "-DBOOST_LIB_DIAGNOSTIC")
-- set_target_properties(Boost::diagnostic_definitions PROPERTIES
-+ set_target_properties(boost_diagnostic_definitions PROPERTIES
- INTERFACE_COMPILE_DEFINITIONS "BOOST_LIB_DIAGNOSTIC")
-- set_target_properties(Boost::disable_autolinking PROPERTIES
-+ set_target_properties(boost_disable_autolinking PROPERTIES
- INTERFACE_COMPILE_DEFINITIONS "BOOST_ALL_NO_LIB")
-- set_target_properties(Boost::dynamic_linking PROPERTIES
-+ set_target_properties(boost_dynamic_linking PROPERTIES
- INTERFACE_COMPILE_DEFINITIONS "BOOST_ALL_DYN_LINK")
- endif()
-
-@@ -2018,52 +2018,52 @@ if(Boost_FOUND)
- endif()
-
- foreach(COMPONENT ${Boost_FIND_COMPONENTS})
-- if(_Boost_IMPORTED_TARGETS AND NOT TARGET Boost::${COMPONENT})
-+ if(_Boost_IMPORTED_TARGETS AND NOT TARGET boost_${COMPONENT})
- string(TOUPPER ${COMPONENT} UPPERCOMPONENT)
- if(Boost_${UPPERCOMPONENT}_FOUND)
- if(Boost_USE_STATIC_LIBS)
-- add_library(Boost::${COMPONENT} STATIC IMPORTED)
-+ add_library(boost_${COMPONENT} STATIC IMPORTED)
- else()
- # Even if Boost_USE_STATIC_LIBS is OFF, we might have static
- # libraries as a result.
-- add_library(Boost::${COMPONENT} UNKNOWN IMPORTED)
-+ add_library(boost_${COMPONENT} UNKNOWN IMPORTED)
- endif()
- if(Boost_INCLUDE_DIRS)
-- set_target_properties(Boost::${COMPONENT} PROPERTIES
-+ set_target_properties(boost_${COMPONENT} PROPERTIES
- INTERFACE_INCLUDE_DIRECTORIES "${Boost_INCLUDE_DIRS}")
- endif()
- if(EXISTS "${Boost_${UPPERCOMPONENT}_LIBRARY}")
-- set_target_properties(Boost::${COMPONENT} PROPERTIES
-+ set_target_properties(boost_${COMPONENT} PROPERTIES
- IMPORTED_LINK_INTERFACE_LANGUAGES "CXX"
- IMPORTED_LOCATION "${Boost_${UPPERCOMPONENT}_LIBRARY}")
- endif()
- if(EXISTS "${Boost_${UPPERCOMPONENT}_LIBRARY_RELEASE}")
-- set_property(TARGET Boost::${COMPONENT} APPEND PROPERTY
-+ set_property(TARGET boost_${COMPONENT} APPEND PROPERTY
- IMPORTED_CONFIGURATIONS RELEASE)
-- set_target_properties(Boost::${COMPONENT} PROPERTIES
-+ set_target_properties(boost_${COMPONENT} PROPERTIES
- IMPORTED_LINK_INTERFACE_LANGUAGES_RELEASE "CXX"
- IMPORTED_LOCATION_RELEASE "${Boost_${UPPERCOMPONENT}_LIBRARY_RELEASE}")
- endif()
- if(EXISTS "${Boost_${UPPERCOMPONENT}_LIBRARY_DEBUG}")
-- set_property(TARGET Boost::${COMPONENT} APPEND PROPERTY
-+ set_property(TARGET boost_${COMPONENT} APPEND PROPERTY
- IMPORTED_CONFIGURATIONS DEBUG)
-- set_target_properties(Boost::${COMPONENT} PROPERTIES
-+ set_target_properties(boost_${COMPONENT} PROPERTIES
- IMPORTED_LINK_INTERFACE_LANGUAGES_DEBUG "CXX"
- IMPORTED_LOCATION_DEBUG "${Boost_${UPPERCOMPONENT}_LIBRARY_DEBUG}")
- endif()
- if(_Boost_${UPPERCOMPONENT}_DEPENDENCIES)
- unset(_Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES)
- foreach(dep ${_Boost_${UPPERCOMPONENT}_DEPENDENCIES})
-- list(APPEND _Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES Boost::${dep})
-+ list(APPEND _Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES boost_${dep})
- endforeach()
- if(COMPONENT STREQUAL "thread")
- list(APPEND _Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES Threads::Threads)
- endif()
-- set_target_properties(Boost::${COMPONENT} PROPERTIES
-+ set_target_properties(boost_${COMPONENT} PROPERTIES
- INTERFACE_LINK_LIBRARIES "${_Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES}")
- endif()
- if(_Boost_${UPPERCOMPONENT}_COMPILER_FEATURES)
-- set_target_properties(Boost::${COMPONENT} PROPERTIES
-+ set_target_properties(boost_${COMPONENT} PROPERTIES
- INTERFACE_COMPILE_FEATURES "${_Boost_${UPPERCOMPONENT}_COMPILER_FEATURES}")
- endif()
- endif()
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 1b1f19d464..21c222280f 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -353,12 +353,12 @@ set(ceph_common_objs
- set(ceph_common_deps
- json_spirit erasure_code arch crc32
- ${LIB_RESOLV}
-- Boost::thread
-- Boost::system
-- Boost::random
-- Boost::program_options
-- Boost::date_time
-- Boost::iostreams
-+ boost_thread
-+ boost_system
-+ boost_random
-+ boost_program_options
-+ boost_date_time
-+ boost_iostreams
- ${BLKID_LIBRARIES}
- ${Backtrace_LIBRARIES}
- ${BLKIN_LIBRARIES}
-@@ -518,7 +518,7 @@ if (WITH_CEPHFS)
- ceph_mds.cc)
- add_executable(ceph-mds ${ceph_mds_srcs})
- target_link_libraries(ceph-mds mds ${CMAKE_DL_LIBS} global-static ceph-common
-- Boost::thread)
-+ boost_thread)
- install(TARGETS ceph-mds DESTINATION bin)
- endif()
-
-diff --git a/src/crimson/CMakeLists.txt b/src/crimson/CMakeLists.txt
-index d7b58521d4..e1533af33f 100644
---- a/src/crimson/CMakeLists.txt
-+++ b/src/crimson/CMakeLists.txt
-@@ -106,8 +106,8 @@ target_link_libraries(crimson-common
- PRIVATE
- crc32
- crimson::cflags
-- Boost::iostreams
-- Boost::random
-+ boost_iostreams
-+ boost_random
- ${NSS_LIBRARIES} ${NSPR_LIBRARIES} OpenSSL::Crypto)
-
- set(crimson_auth_srcs
-diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
-index 252fb3e5e3..3f3823a68e 100644
---- a/src/mgr/CMakeLists.txt
-+++ b/src/mgr/CMakeLists.txt
-@@ -26,7 +26,7 @@ target_include_directories(ceph-mgr SYSTEM PRIVATE "${PYTHON_INCLUDE_DIRS}")
- target_link_libraries(ceph-mgr
- osdc client heap_profiler
- global-static ceph-common
-- Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
-+ boost_python-${MGR_PYTHON_VERSION_MAJOR}.${MGR_PYTHON_VERSION_MINOR}
- ${MGR_PYTHON_LIBRARIES} ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
- set_target_properties(ceph-mgr PROPERTIES
- POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
-diff --git a/src/rbd_replay/CMakeLists.txt b/src/rbd_replay/CMakeLists.txt
-index e9d3804c5f..5c6eb58de1 100644
---- a/src/rbd_replay/CMakeLists.txt
-+++ b/src/rbd_replay/CMakeLists.txt
-@@ -36,7 +36,7 @@ if(HAVE_BABELTRACE)
- global
- babeltrace
- babeltrace-ctf
-- Boost::date_time
-+ boost_date_time
- )
- install(TARGETS rbd-replay-prep DESTINATION bin)
- endif(HAVE_BABELTRACE)
-diff --git a/src/rgw/CMakeLists.txt b/src/rgw/CMakeLists.txt
-index ccc4f74cfe..854aa6e5e9 100644
---- a/src/rgw/CMakeLists.txt
-+++ b/src/rgw/CMakeLists.txt
-@@ -199,7 +199,7 @@ if(WITH_CURL_OPENSSL)
- endif()
-
- if(WITH_BOOST_CONTEXT)
-- target_link_libraries(rgw_a PRIVATE Boost::coroutine Boost::context)
-+ target_link_libraries(rgw_a PRIVATE boost_coroutine boost_context)
- endif()
-
- set(rgw_libs rgw_a)
-@@ -341,7 +341,7 @@ if(WITH_RADOSGW_AMQP_ENDPOINT)
- target_link_libraries(rgw_admin_user PRIVATE RabbitMQ::RabbitMQ)
- endif()
- if(WITH_BOOST_CONTEXT)
-- target_link_libraries(rgw_admin_user PRIVATE Boost::coroutine Boost::context)
-+ target_link_libraries(rgw_admin_user PRIVATE boost_coroutine boost_context)
- endif()
-
- if(WITH_TESTS)
-diff --git a/src/test/CMakeLists.txt b/src/test/CMakeLists.txt
-index 20a64fd41b..a8bb323614 100644
---- a/src/test/CMakeLists.txt
-+++ b/src/test/CMakeLists.txt
-@@ -158,7 +158,7 @@ add_executable(ceph_omapbench
- )
- target_link_libraries(ceph_omapbench
- librados
-- Boost::program_options
-+ boost_program_options
- global
- ${BLKID_LIBRARIES}
- ${CMAKE_DL_LIBS}
-diff --git a/src/test/common/CMakeLists.txt b/src/test/common/CMakeLists.txt
-index 71fb77cda9..aff8fb6565 100644
---- a/src/test/common/CMakeLists.txt
-+++ b/src/test/common/CMakeLists.txt
-@@ -315,8 +315,8 @@ add_ceph_unittest(unittest_hobject)
-
- add_executable(unittest_async_completion test_async_completion.cc)
- add_ceph_unittest(unittest_async_completion)
--target_link_libraries(unittest_async_completion Boost::system)
-+target_link_libraries(unittest_async_completion boost_system)
-
- add_executable(unittest_async_shared_mutex test_async_shared_mutex.cc)
- add_ceph_unittest(unittest_async_shared_mutex)
--target_link_libraries(unittest_async_shared_mutex ceph-common Boost::system)
-+target_link_libraries(unittest_async_shared_mutex ceph-common boost_system)
-diff --git a/src/test/erasure-code/CMakeLists.txt b/src/test/erasure-code/CMakeLists.txt
-index 721f6c3675..1cd9635c77 100644
---- a/src/test/erasure-code/CMakeLists.txt
-+++ b/src/test/erasure-code/CMakeLists.txt
-@@ -2,15 +2,15 @@
- add_executable(ceph_erasure_code_benchmark
- ${CMAKE_SOURCE_DIR}/src/erasure-code/ErasureCode.cc
- ceph_erasure_code_benchmark.cc)
--target_link_libraries(ceph_erasure_code_benchmark ceph-common Boost::program_options global ${CMAKE_DL_LIBS})
-+target_link_libraries(ceph_erasure_code_benchmark ceph-common boost_program_options global ${CMAKE_DL_LIBS})
- install(TARGETS ceph_erasure_code_benchmark
- DESTINATION bin)
-
- add_executable(ceph_erasure_code_non_regression ceph_erasure_code_non_regression.cc)
--target_link_libraries(ceph_erasure_code_non_regression ceph-common Boost::program_options global ${CMAKE_DL_LIBS})
-+target_link_libraries(ceph_erasure_code_non_regression ceph-common boost_program_options global ${CMAKE_DL_LIBS})
-
- add_executable(ceph_erasure_code ceph_erasure_code.cc)
--target_link_libraries(ceph_erasure_code ceph-common Boost::program_options global ${CMAKE_DL_LIBS})
-+target_link_libraries(ceph_erasure_code ceph-common boost_program_options global ${CMAKE_DL_LIBS})
- install(TARGETS ceph_erasure_code
- DESTINATION bin)
-
-diff --git a/src/test/librados/CMakeLists.txt b/src/test/librados/CMakeLists.txt
-index 4fc53d2406..e6304394f8 100644
---- a/src/test/librados/CMakeLists.txt
-+++ b/src/test/librados/CMakeLists.txt
-@@ -62,7 +62,7 @@ add_executable(ceph_test_rados_api_asio asio.cc)
- target_link_libraries(ceph_test_rados_api_asio global
- librados ${UNITTEST_LIBS})
- if(WITH_BOOST_CONTEXT)
-- target_link_libraries(ceph_test_rados_api_asio Boost::coroutine Boost::context)
-+ target_link_libraries(ceph_test_rados_api_asio boost_coroutine boost_context)
- endif()
-
- add_executable(ceph_test_rados_api_list
-@@ -132,7 +132,7 @@ add_executable(ceph_test_rados_api_tier_pp
- tier_cxx.cc
- $<TARGET_OBJECTS:unit-main>)
- target_link_libraries(ceph_test_rados_api_tier_pp
-- librados global ${UNITTEST_LIBS} Boost::system radostest-cxx)
-+ librados global ${UNITTEST_LIBS} boost_system radostest-cxx)
-
- add_executable(ceph_test_rados_api_snapshots
- snapshots.cc)
-diff --git a/src/test/librbd/CMakeLists.txt b/src/test/librbd/CMakeLists.txt
-index 2bf6723c40..e99b8afa11 100644
---- a/src/test/librbd/CMakeLists.txt
-+++ b/src/test/librbd/CMakeLists.txt
-@@ -27,7 +27,7 @@ target_link_libraries(rbd_test PRIVATE
- radostest
- radostest-cxx
- librados
-- Boost::thread
-+ boost_thread
- GMock::GMock
- GTest::GTest)
-
-diff --git a/src/test/rgw/CMakeLists.txt b/src/test/rgw/CMakeLists.txt
-index 9b2c6b6321..80e4cb7829 100644
---- a/src/test/rgw/CMakeLists.txt
-+++ b/src/test/rgw/CMakeLists.txt
-@@ -143,7 +143,7 @@ add_ceph_unittest(unittest_rgw_dmclock_scheduler)
- target_link_libraries(unittest_rgw_dmclock_scheduler ${rgw_libs} dmclock)
- if(WITH_BOOST_CONTEXT)
- target_compile_definitions(unittest_rgw_dmclock_scheduler PRIVATE BOOST_COROUTINES_NO_DEPRECATION_WARNING)
-- target_link_libraries(unittest_rgw_dmclock_scheduler Boost::coroutine Boost::context)
-+ target_link_libraries(unittest_rgw_dmclock_scheduler boost_coroutine boost_context)
- endif()
-
- if(WITH_RADOSGW_AMQP_ENDPOINT)
-diff --git a/src/tools/CMakeLists.txt b/src/tools/CMakeLists.txt
-index d31f3d2408..6945018b11 100644
---- a/src/tools/CMakeLists.txt
-+++ b/src/tools/CMakeLists.txt
-@@ -35,20 +35,20 @@ install(PROGRAMS
- endif(WITH_TESTS)
-
- add_executable(ceph-osdomap-tool ceph_osdomap_tool.cc)
--target_link_libraries(ceph-osdomap-tool os global Boost::program_options)
-+target_link_libraries(ceph-osdomap-tool os global boost_program_options)
- install(TARGETS ceph-osdomap-tool DESTINATION bin)
-
- add_executable(ceph-monstore-tool
- ceph_monstore_tool.cc
- ../mgr/mgr_commands.cc)
--target_link_libraries(ceph-monstore-tool os global Boost::program_options)
-+target_link_libraries(ceph-monstore-tool os global boost_program_options)
- install(TARGETS ceph-monstore-tool DESTINATION bin)
-
- add_executable(ceph-objectstore-tool
- ceph_objectstore_tool.cc
- rebuild_mondb.cc
- RadosDump.cc)
--target_link_libraries(ceph-objectstore-tool osd os global Boost::program_options ${CMAKE_DL_LIBS})
-+target_link_libraries(ceph-objectstore-tool osd os global boost_program_options ${CMAKE_DL_LIBS})
- if(WITH_FUSE)
- target_link_libraries(ceph-objectstore-tool ${FUSE_LIBRARIES})
- endif(WITH_FUSE)
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-cflags.patch b/sys-cluster/ceph/files/ceph-14.2.0-cflags.patch
deleted file mode 100644
index 3a9f52c879b7..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-cflags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/cmake/modules/Distutils.cmake b/cmake/modules/Distutils.cmake
-index 5697dff85f..7fdcfe4112 100644
---- a/cmake/modules/Distutils.cmake
-+++ b/cmake/modules/Distutils.cmake
-@@ -61,7 +61,7 @@ function(distutils_add_cython_module name src)
- CC="${PY_CC}"
- CXX="${PY_CXX}"
- LDSHARED="${PY_LDSHARED}"
-- OPT=\"-DNDEBUG -g -fwrapv -O2 -w\"
-+ OPT=\"-DNDEBUG -g -fwrapv -w\"
- LDFLAGS=-L${CMAKE_LIBRARY_OUTPUT_DIRECTORY}
- CYTHON_BUILD_DIR=${CMAKE_CURRENT_BINARY_DIR}
- CEPH_LIBDIR=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-dpdk-cflags.patch b/sys-cluster/ceph/files/ceph-14.2.0-dpdk-cflags.patch
deleted file mode 100644
index ab5d980cfbc9..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-dpdk-cflags.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/cmake/modules/BuildDPDK.cmake b/cmake/modules/BuildDPDK.cmake
-index 12a831a8b1..a5485aa205 100644
---- a/cmake/modules/BuildDPDK.cmake
-+++ b/cmake/modules/BuildDPDK.cmake
-@@ -16,17 +16,14 @@ function(do_build_dpdk dpdk_dir)
- set(arch "x86_64")
- set(machine "default")
- set(machine_tmpl "native")
-- set(rte_cflags "-march=core2")
- elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "arm|ARM")
- set(arch "arm")
- set(machine "armv7a")
- set(machine_tmpl "armv7a")
-- set(rte_cflags "-march=armv7-a")
- elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "aarch64|AARCH64")
- set(arch "arm64")
- set(machine "armv8a")
- set(machine_tmpl "armv8a")
-- set(rte_cflags "-march=armv8-a+crc")
- elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "(powerpc|ppc)64")
- set(arch "ppc_64")
- set(machine "power8")
-@@ -35,7 +32,6 @@ function(do_build_dpdk dpdk_dir)
- message(FATAL_ERROR "not able to build DPDK support: "
- "unknown arch \"${CMAKE_SYSTEM_PROCESSOR}\"")
- endif()
-- set(dpdk_rte_CFLAGS "${rte_cflags}" CACHE INTERNAL "")
- if(CMAKE_SYSTEM_NAME MATCHES "Linux")
- set(execenv "linuxapp")
- elseif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch b/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
deleted file mode 100644
index ec7a4fb079b3..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ceph-14.2.0.orig/src/common/CMakeLists.txt 2019-03-18 04:08:29.000000000 -0600
-+++ ceph-14.2.0/src/common/CMakeLists.txt 2019-03-21 18:42:32.903182824 -0600
-@@ -165,7 +165,7 @@
- crc32c_aarch64.c)
- endif(HAVE_INTEL)
-
--add_library(crc32 ${crc32_srcs})
-+add_library(crc32 STATIC ${crc32_srcs})
- if(HAVE_ARMV8_CRC)
- set_target_properties(crc32 PROPERTIES
- COMPILE_FLAGS "${CMAKE_C_FLAGS} ${ARMV8_CRC_COMPILE_FLAGS}")
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-mgr-python-version.patch b/sys-cluster/ceph/files/ceph-14.2.0-mgr-python-version.patch
deleted file mode 100644
index e4502a608ec2..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-mgr-python-version.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/pybind/CMakeLists.txt b/src/pybind/CMakeLists.txt
-index 664543172a..e74d73c084 100644
---- a/src/pybind/CMakeLists.txt
-+++ b/src/pybind/CMakeLists.txt
-@@ -62,12 +62,6 @@ foreach(python_version ${py_vers})
- endforeach()
-
- if(WITH_MGR)
-- if(NOT WITH_PYTHON2 AND MGR_PYTHON_VERSION_MAJOR EQUAL 2)
-- message(FATAL_ERROR "mgr plugins require python2 binding")
-- elseif(NOT WITH_PYTHON3 AND MGR_PYTHON_VERSION_MAJOR EQUAL 3)
-- message(FATAL_ERROR "mgr plugins require python3 binding")
-- endif()
--
- if(USE_OPENSSL)
- execute_process(
- COMMAND ${PYTHON${PYTHON_VERSION}_EXECUTABLE} -c "import ssl; print('.'.join(map(str,ssl.OPENSSL_VERSION_INFO[0:3])))"
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-14.2.0-no-virtualenvs.patch
deleted file mode 100644
index 5647ac51674d..000000000000
--- a/sys-cluster/ceph/files/ceph-14.2.0-no-virtualenvs.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/.gitignore b/.gitignore
-index 2c2afc282e..80c05ee2f0 100644
---- a/.gitignore
-+++ b/.gitignore
-@@ -13,10 +13,8 @@
- *.swp
- *.swo
- *.tmp
--*.orig
- *.patch
- !debian/patches/*.patch
--*.rej
- *.rpm
- *.pyc
- ceph.spec
-diff --git a/src/pybind/mgr/dashboard/CMakeLists.txt b/src/pybind/mgr/dashboard/CMakeLists.txt
-index 24a2efc9e2..b11d4d0303 100644
---- a/src/pybind/mgr/dashboard/CMakeLists.txt
-+++ b/src/pybind/mgr/dashboard/CMakeLists.txt
-@@ -2,7 +2,7 @@ set(MGR_DASHBOARD_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/mgr-dashboard-virtualenv)
-
- add_custom_target(mgr-dashboard-test-venv
- COMMAND
-- ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${MGR_DASHBOARD_VIRTUALENV}
-+ #${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${MGR_DASHBOARD_VIRTUALENV}
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/pybind/mgr/dashboard
- COMMENT "dashboard tests virtualenv is being created")
- add_dependencies(tests mgr-dashboard-test-venv)
-@@ -14,9 +14,9 @@ function(add_npm_command)
- set(multi_kw COMMAND DEPENDS)
- cmake_parse_arguments(NC "${options}" "${single_kw}" "${multi_kw}" ${ARGN})
- string(REPLACE ";" " " command "${NC_COMMAND}")
-- if(NC_NODEENV)
-- string(REGEX REPLACE "^(npm .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
-- endif()
-+ #if(NC_NODEENV)
-+ # string(REGEX REPLACE "^(npm .*)$" ". ${mgr-dashboard-nodeenv-dir}/bin/activate && \\1 && deactivate" command ${command})
-+ #endif()
- string(REPLACE " " ";" command "${command}")
- add_custom_command(
- OUTPUT "${NC_OUTPUT}"
-@@ -41,9 +41,9 @@ else()
-
- add_custom_command(
- OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
-- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv -p --node=10.13.0
-+ #COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
-+ #COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
-+ #COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv -p --node=10.13.0
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
- COMMENT "dashboard nodeenv is being installed"
- )