summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch b/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
new file mode 100644
index 000000000000..e50030071c81
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
@@ -0,0 +1,12 @@
+diff --git a/src/rgw/store/dbstore/CMakeLists.txt b/src/rgw/store/dbstore/CMakeLists.txt
+index 143ede3c094..204ef653010 100644
+--- a/src/rgw/store/dbstore/CMakeLists.txt
++++ b/src/rgw/store/dbstore/CMakeLists.txt
+@@ -24,6 +24,7 @@ if(WITH_JAEGER)
+ list(APPEND link_targets ${jaeger_base})
+ endif()
+ target_link_libraries(dbstore_lib PUBLIC ${link_targets})
++install(TARGETS dbstore_lib DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} dbstore_lib)
+