summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files/ceph-16.2.9-python310.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.9-python310.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-16.2.9-python310.patch b/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
new file mode 100644
index 000000000000..403cfe2f3d1d
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
@@ -0,0 +1,12 @@
+diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
+index 38aad299ccb..8e152e060ea 100644
+--- a/src/mgr/CMakeLists.txt
++++ b/src/mgr/CMakeLists.txt
+@@ -34,6 +34,7 @@ if(WITH_MGR)
+ mgr_commands.cc
+ $<TARGET_OBJECTS:mgr_cap_obj>)
+ add_executable(ceph-mgr ${mgr_srcs})
++ target_compile_definitions(ceph-mgr PRIVATE PY_SSIZE_T_CLEAN)
+ target_link_libraries(ceph-mgr
+ osdc client heap_profiler
+ global-static ceph-common