summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/Manifest.gzbin5901 -> 5907 bytes
-rw-r--r--sys-boot/plymouth-openrc-plugin/Manifest2
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild34
3 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/Manifest.gz b/sys-boot/Manifest.gz
index c1ae8f8e4177..7025f5830ee3 100644
--- a/sys-boot/Manifest.gz
+++ b/sys-boot/Manifest.gz
Binary files differ
diff --git a/sys-boot/plymouth-openrc-plugin/Manifest b/sys-boot/plymouth-openrc-plugin/Manifest
index 4ff8d565aeea..ec813eeefd23 100644
--- a/sys-boot/plymouth-openrc-plugin/Manifest
+++ b/sys-boot/plymouth-openrc-plugin/Manifest
@@ -1,3 +1,5 @@
DIST plymouth-openrc-plugin-0.1.3.tar.gz 9404 BLAKE2B 809cfab881ef47565badfc330b77ae07a8bbbddf822cbdb50f2d1d2a0c95f915ac5024e02400ab2ea9d8f98dc466a8a3cbad92805587f77a00e58c9f9d78d388 SHA512 b07a4d9d56c8f49d5b0a91799fe0100eac705cd2a266674539948fdc661876474a93d8ed5f329f097a1fc5dc571f3b3c00322191fb77d2a7e32b1ff192ca0a6b
+DIST plymouth-openrc-plugin-0.2.0.tar.gz 10325 BLAKE2B ee66b158d366f5bf12504d1546ec00906f9e73760308975dbc4ea26e5622ee10ab877b47a13269ae11576c7d3e8b4c9484ca0dc61efce0f78f38344515ce4c5e SHA512 4156b291c49cf5c55c78071439530a35f5ec03b1e022bb022839e1b89567653ebb70bf3471b82ae0ecec8fc84c3f41ee2cc6b3de1fa52811a96d0812a6ada772
EBUILD plymouth-openrc-plugin-0.1.3.ebuild 747 BLAKE2B 8e572b805ec906c17ef5640b44ec7a518d447f5db15995206f59cf170bb6f61ef1f2517c2ebee6b7b223e63492b934394bbe4c10e2b04f053c51e1047a7d000d SHA512 57c074f4e83ad7866bbd6f971b9866d072fc1f948238cfd377dc2ee397e811aceea32c9145d34743888e3e59f4416746b0dd3b6dfd51c4556e4b382a8120e8af
+EBUILD plymouth-openrc-plugin-0.2.0.ebuild 791 BLAKE2B f6e3e0971386c92e841b27371c521c0367f67239ad04ca25842ce35cf8a95b464999bc84d746025a61d2f0ae110705959c8719acd531e7a336f3464838c3d385 SHA512 016195872da5d279e437941c8780309b06e58d77ae2f36c42f7d61458eb5f81be118e7f35e9a225035de9b2ae8e97ca244c210dcc1fb48449156864362e71876
MISC metadata.xml 448 BLAKE2B 9ac1f7e0f16731cf3b61581d4700c2337671d3c299a617816e0e44e3ad330b1763e765b52ba970ef65abdf8ebfd832cf932b671ed3a4602d0acb0aec175a212d SHA512 2e42ea8aaf4ed4703c0f7c2318002f5edf470bfe51bad1578054832ccacd283de9f3d7b1d8e8864a7ab9365214ebd9c3d4a3978ba1fce951ae7a231910cf21fe
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
new file mode 100644
index 000000000000..6d409e02a6d6
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/Kangie/plymouth-openrc-plugin"
+SRC_URI="https://github.com/Kangie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="sys-apps/openrc"
+RDEPEND="${DEPEND}
+ sys-boot/plymouth
+ !sys-apps/systemd"
+
+src_configure() {
+ local emesonargs=(
+ -Ddebug=$(usex debug true false)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "The 'rc_interactive' feature in /etc/rc.conf must be disabled"
+ ewarn "for Plymouth work properly with OpenRC init system."
+ fi
+}