summaryrefslogtreecommitdiff
path: root/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild')
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
new file mode 100644
index 000000000000..531874033bde
--- /dev/null
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.17-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe.
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
+HOMEPAGE="http://yaboot.ozlabs.org/"
+SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ppc ppc64"
+IUSE="ibm"
+
+DEPEND="sys-apps/powerpc-utils"
+RDEPEND="!sys-boot/yaboot
+ !ibm? (
+ sys-fs/hfsutils
+ sys-fs/hfsplusutils
+ sys-fs/mac-fdisk
+ )"
+
+S=${WORKDIR}
+
+QA_PRESTRIPPED="
+ /usr/lib/yaboot/yaboot
+ /usr/lib/yaboot/yaboot.chrp
+ /usr/lib/yaboot/addnote
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/new-ofpath-devspec.patch"
+}
+
+src_install() {
+ cp -pPR "${WORKDIR}"/* "${D}" || die
+}