summaryrefslogtreecommitdiff
path: root/sys-boot/shim/shim-15.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/shim/shim-15.5.ebuild')
-rw-r--r--sys-boot/shim/shim-15.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-boot/shim/shim-15.5.ebuild b/sys-boot/shim/shim-15.5.ebuild
new file mode 100644
index 000000000000..e946b3ad5dc2
--- /dev/null
+++ b/sys-boot/shim/shim-15.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rpm
+
+DESCRIPTION="Fedora's signed UEFI shim"
+HOMEPAGE="https://apps.fedoraproject.org/packages/shim/"
+MY_PV="${PV/./-}"
+SRC_URI="amd64? ( https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-x64-${MY_PV}.x86_64.rpm
+ https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-ia32-${MY_PV}.x86_64.rpm )
+ arm64? ( https://kojipkgs.fedoraproject.org//packages/shim/15/5/aarch64/shim-aa64-${MY_PV}.aarch64.rpm )
+ x86? ( https://kojipkgs.fedoraproject.org//packages/shim/15/5/x86_64/shim-ia32-${MY_PV}.x86_64.rpm )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/boot/efi/EFI"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins BOOT/BOOT*.EFI
+ doins fedora/mm*.efi
+}